summaryrefslogtreecommitdiff
path: root/libre/icecat/PKGBUILD
diff options
context:
space:
mode:
authorcoadde [Márcio Alexandre Silva Delgado] <coadde@parabola.nu>2014-10-21 18:44:23 -0200
committercoadde [Márcio Alexandre Silva Delgado] <coadde@parabola.nu>2014-10-21 18:44:23 -0200
commitbbca5e0d2098b8e140c78a7a1774a48cabdc79bf (patch)
tree29926d24bb2ea6753dcdb0224a8a37a557d2d4b1 /libre/icecat/PKGBUILD
parent888d92d920617851e7eb099c59f7b583f8e88636 (diff)
downloadabslibre-bbca5e0d2098b8e140c78a7a1774a48cabdc79bf.tar.gz
abslibre-bbca5e0d2098b8e140c78a7a1774a48cabdc79bf.tar.bz2
abslibre-bbca5e0d2098b8e140c78a7a1774a48cabdc79bf.zip
update icecat to 31.1.1
Diffstat (limited to 'libre/icecat/PKGBUILD')
-rw-r--r--libre/icecat/PKGBUILD231
1 files changed, 126 insertions, 105 deletions
diff --git a/libre/icecat/PKGBUILD b/libre/icecat/PKGBUILD
index 5422c8a99..255cef95a 100644
--- a/libre/icecat/PKGBUILD
+++ b/libre/icecat/PKGBUILD
@@ -1,90 +1,119 @@
# Maintainer: André Silva <emulatorman@parabola.nu>
-# Maintainer: Márcio Silva <coadde@parabola.nu>
+# Contributor: Márcio Silva <coadde@parabola.nu>
# Contributor (ConnochaetOS): Henry Jensen <hjensen@connochaetos.org>
# Contributor: Luke Shumaker <lukeshu@sbcglobal.net>
-# Contributor: Figue <ffigue at gmail>
# Contributor: fauno <fauno@kiwwwi.com.ar>
# Contributor: vando <facundo@esdebian.org>
# Contributor (Arch): Jakub Schmidtke <sjakub@gmail.com>
+# Contributor: Figue <ffigue at gmail>
# Thank you very much to the older contributors:
# Contributor: evr <evanroman at gmail>
# Contributor: Muhammad 'MJ' Jassim <UnbreakableMJ@gmail.com>
-_pgo=false
+_pgo=true
pkgname=icecat
-pkgver=24.0
-pkgrel=5
-pkgdesc='GNU IceCat, the standalone web browser based on Mozilla Firefox.'
+pkgver=31.1.1
+pkgrel=1
+
+pkgdesc="GNU IceCat, the standalone web browser based on Mozilla Firefox."
arch=(i686 x86_64 mips64el)
license=(MPL GPL LGPL)
-depends=(alsa-lib dbus-glib desktop-file-utils gtk2 hicolor-icon-theme hunspell libevent libnotify libvpx libxt mime-types mozilla-common mozilla-searchplugins nss sqlite startup-notification)
-makedepends=(autoconf2.13 diffutils gstreamer0.10-base imagemagick imake inetutils libidl2 libpulse librsvg libxslt mesa pkg-config python2 unzip zip)
-options=(!emptydirs !makeflags)
+depends=(alsa-lib dbus-glib desktop-file-utils gtk2 hicolor-icon-theme hunspell icu libevent libnotify libvpx libxt mime-types mozilla-common mozilla-searchplugins nss sqlite startup-notification)
+makedepends=(autoconf2.13 diffutils gst-plugins-base-libs imagemagick imake inetutils libidl2 libpulse librsvg libxslt mesa pkg-config python2 quilt unzip zip)
+[ "$CARCH" != "mips64el" ] && makedepends+=('yasm')
+options=(!emptydirs !makeflags debug)
if $_pgo; then
makedepends+=(xorg-server-xvfb)
options+=(!ccache)
fi
optdepends=('networkmanager: Location detection via available WiFi networks'
- 'gstreamer0.10-base-plugins: vorbis decoding, ogg demuxing'
- 'gstreamer0.10-good-plugins: webm and mp4 demuxing'
- 'gstreamer0.10-bad-plugins: aac, vp8 and opus decoding'
- 'gstreamer0.10-ugly-plugins: h.264 and mp3 decoding'
- 'gstreamer0.10-ffmpeg: more decoders'
- 'libpulse: PulseAudio audio driver')
-url=http://www.gnu.org/software/gnuzilla/
+ 'gst-plugins-good: h.264 video'
+ 'gst-libav: h.264 video')
+url="http://www.gnu.org/software/gnuzilla/"
install=$pkgname.install
-source=(
- ftp://ftp.gnu.org/gnu/gnuzilla/${pkgver::2}/$pkgname-$pkgver.tar.gz
- mozconfig
- mozconfig.pgo
- libre.patch
- $pkgname.desktop
- $pkgname-safe.desktop
- $pkgname-install-dir.patch
- vendor.js
- icecat-20.0.1-fixed-loading-icon.png
-)
-
-md5sums=(
- 0d3fdcec3f5fde494dedb595387e8f21
- 71dce16848bc51503a154841ce99427b
- df08eaa1ac3bc6c2356be4fbf8ec8932
- 21b5014c55aa97983f833886e047f55c
- b41f82994fa056ffa5f8e6d99570e27a
- b30ba2b5562558d510fdd09d626d0faa
- 64826fcf48816b13090042eefddbaa58
- 1dfa11e781950a969205e83840e9741e
- 6e335a517c68488941340ee1c23f97b0
-)
+source=("http://gnuzilla.gnu.org/releases/$pkgver/$pkgname-$pkgver.tar.xz"
+ mozconfig
+ mozconfig.pgo
+ libre.patch
+ gnu_headshadow.png
+ $pkgname.desktop
+ $pkgname-install-dir.patch
+ vendor.js
+ rhbz-966424.patch
+ $pkgname-fixed-loading-icon.png)
+md5sums=('1c7220cebc05910396ba2b09cfecd9ce'
+ '922d212e567e59a5894787b859f99ecc'
+ 'df08eaa1ac3bc6c2356be4fbf8ec8932'
+ '15e9b24deb5d09b359691658db7f3fd2'
+ 'b03a979a78484503ba8dddad4f2c96d1'
+ '936eeb4cadad656528c87b963a689583'
+ '7b2213f23f7dec017f67257b9fd2780f'
+ 'afafa89b727642c33ade82f2ffbe64a7'
+ '16a112aaeee34ff3cae1fc1a521448a0'
+ '6e335a517c68488941340ee1c23f97b0')
prepare() {
- mv $pkgname-$pkgver $srcdir/gnuzilla-build
- cd $srcdir/gnuzilla-build
+ export GNU_BUILD="gnuzilla-release"
- cp $srcdir/mozconfig .mozconfig # Load our build config, disable SafeSearch
+ mv $pkgname-$pkgver "$srcdir/$GNU_BUILD"
+ cd "$srcdir/$GNU_BUILD"
- if $_pgo; then
- cat $srcdir/mozconfig.pgo >> .mozconfig
- fi
- patch -Np1 -i $srcdir/$pkgname-install-dir.patch # install to /usr/lib/$pkgname
+
+ # Put gnu_headshadow.png on the source code
+ install -m644 "$srcdir/gnu_headshadow.png" \
+ browser/base/content/abouthome
+
+ # Install to /usr/lib/$pkgname
+ patch -Np1 -i "$srcdir/$pkgname-install-dir.patch"
+
+ # https://bugs.archlinux.org/task/41689
+ patch -Np1 -i "$srcdir/rhbz-966424.patch"
# Patch and remove anything that's left
- patch -Np1 -i $srcdir/libre.patch
+ patch -Np1 -i "$srcdir/libre.patch"
sed -i 's|Adobe Flash|SWF Player|g;
' browser/base/content/pageinfo/permissions.js \
browser/base/content/browser-plugins.js
- sed -i '\|URL of the GeoLocation backend|d;
- \|geo[.]wifi[.]uri|d;
+ sed -i '\|["]displayName["][:] ["]Flash["]| s|Flash|SWF Player|
+ \|["]displayName["][:] ["]Shockwave["]| s|Shockwave|DCR Player|
+ \|["]displayName["][:] ["]QuickTime["]| s|QuickTime|MOV Player|
+ \|installLinux| s|true|false|
+ ' browser/base/content/browser-plugins.js
+ rm -v browser/base/content/abouthome/snippet*.png || true
+ sed -i '\|abouthome/snippet|d
+ ' browser/base/jar.mn
+
+ # Replace common URLs
+ sed -i '\|extensions[.]getAddons[.]get[.]url| s|https://services[.]addons[.]mozilla[.]org.\+["][)][;]|https://trisquel.info/en/browser");|g;
+ \|extensions[.]getAddons[.]search[.]browseURL| s|https://addons[.]mozilla[.]org.\+["][)][;]|https://trisquel.info/en/browser");|g;
+ \|extensions[.]getAddons[.]search[.]url| s|https://services[.]addons[.]mozilla[.]org.\+["][)][;]|https://trisquel.info/en/browser");|g;
+ \|extensions[.]webservice[.]discoverURL| s|https://services[.]addons[.]mozilla[.]org.\+["][)][;]|https://trisquel.info/en/browser");|g;
+ \|browser[.]search[.]searchEnginesURL| s|https://addons[.]mozilla[.]org.\+["][)][;]|https://trisquel.info/en/browser");|g;
+ \|plugins[.]update[.]url| s|https://www[.]mozilla[.]org/[%]LOCALE[%]/plugincheck/["][)][;]|https://trisquel.info/en/browser");|g;
' browser/app/profile/firefox.js
- # Fix for use nspr, sqlite and nss external
- sed -i 's/\(MOZ_PKG_FATAL_WARNINGS =\).*/\1 0/' \
- browser/installer/Makefile.in
+ # Load our build config, disable SafeSearch
+ cp "$srcdir/mozconfig" .mozconfig
+
+ if $_pgo; then
+ cat "$srcdir/mozconfig.pgo" >> .mozconfig
+ fi
+
+ # From js on abslibre-mips64el.git
+ if [ "$CARCH" = "mips64el" ]; then
+ msg "Force disabling JIT."
+ sed -ri 's/#define ENABLE_(JIT|ASSEMBLER) 1/#define ENABLE_\1 0/' \
+ js/src/assembler/wtf/Platform.h
+ sed -ri 's/ENABLE_(JIT|ASSEMBLER)=1/ENABLE_\1=0/' js/src/Makefile.{in,ref}
+
+ echo "ac_add_options --disable-methodjit" >> .mozconfig
+ echo "ac_add_options --disable-tracejit" >> .mozconfig
+ fi
# This is a bug, we should fix it
- if [ $CARCH = mips64el ]; then
+ if [ "$CARCH" = "mips64el" ]; then
# Fix MIPS N32 support.
sed -i 's/defined(_ABIO32)/(defined(_ABIO32) || defined(_ABIN32))/' \
js/src/assembler/wtf/Platform.h
@@ -97,15 +126,6 @@ prepare() {
echo 'ac_add_options --disable-jemalloc' >> .mozconfig
fi
- # disable necko-wifi and wireless_tools in IceCat
- #echo 'ac_add_options --disable-necko-wifi' >> .mozconfig
-
- chmod +x build/unix/run-icecat.sh # fix bug for bad file permition
-
- # Fix PRE_RELEASE_SUFFIX
- sed -i '/^PRE_RELEASE_SUFFIX := ""/s/ ""//' \
- browser/base/Makefile.in
-
mkdir "$srcdir/path"
# WebRTC build tries to execute "python" and expects Python 2
@@ -120,69 +140,70 @@ prepare() {
# Fix tab loading icon (flickers with libpng 1.6)
# https://bugzilla.mozilla.org/show_bug.cgi?id=841734
- cp "$srcdir/icecat-20.0.1-fixed-loading-icon.png" \
+ # TODO: Remove this; IceCat 36 might use CSS animations for the loading icon
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=759252
+ cp "$srcdir/$pkgname-fixed-loading-icon.png" \
browser/themes/linux/tabbrowser/loading.png
+
+ # Remove non-existent file on Makefile.in
+ sed -i '\|build/pgo/blueprint/valid.png|d' build/Makefile.in
}
build() {
- cd $srcdir/gnuzilla-build
+ export GNU_BUILD="gnuzilla-release"
+
+ cd "$srcdir/$GNU_BUILD"
export PATH="$srcdir/path:$PATH"
export LDFLAGS="$LDFLAGS -Wl,-rpath,/usr/lib/$pkgname"
export PYTHON="/usr/bin/python2"
- if [[ $CARCH == i686 ]]; then
- # Work around memory address space exhaustion during linking on i686
- LDFLAGS+=' -Wl,--no-keep-memory'
- fi
-
if $_pgo; then
- if [[ $CARCH != i686 ]]; then
- # Set up PGO
- export DISPLAY=:99
- Xvfb -nolisten tcp -extension GLX -screen 0 1280x1024x24 $DISPLAY &
-
- if ! make -f client.mk build MOZ_PGO=1; then
- kill $!
- return 1
- fi
-
- kill $! || true
- else
- make -f client.mk build
- fi
+ # Do PGO
+ xvfb-run -a -s "-extension GLX -screen 0 1280x1024x24" \
+ make -f client.mk build MOZ_PGO=1
else
make -f client.mk build
fi
}
package() {
- cd $srcdir/gnuzilla-build
- make -j1 -f client.mk DESTDIR=$pkgdir install
+ export GNU_BUILD="gnuzilla-release"
+
+ cd "$srcdir/$GNU_BUILD"
+ make -f client.mk DESTDIR="$pkgdir" INSTALL_SDK= install
install -Dm644 ../vendor.js "$pkgdir/usr/lib/$pkgname/browser/defaults/preferences/vendor.js"
+
brandingdir=browser/branding/unofficial
- icondir=$pkgdir/usr/share/icons/hicolor
+ icondir="$pkgdir/usr/share/icons/hicolor"
for i in 16x16 32x32 48x48; do
- install -Dm644 $brandingdir/default${i/x*/}.png $icondir/$i/apps/$pkgname.png
- done
-
- for d in $pkgname $pkgname-safe; do
- install -Dm644 $srcdir/$d.desktop $pkgdir/usr/share/applications/$d.desktop
+ install -Dm644 "$brandingdir/default${i/x*/}.png" "$icondir/$i/apps/$pkgname.png"
done
-
- rm -rf $pkgdir/usr/lib/$pkgname/{dictionaries,hyphenation}
- ln -sf /usr/share/hunspell $pkgdir/usr/lib/$pkgname/dictionaries
- ln -sf /usr/share/hyphen $pkgdir/usr/lib/$pkgname/hyphenation
-
- rm -rf $pkgdir/usr/lib/$pkgname/browser/{searchplugins,plugins}
- ln -sf /usr/lib/mozilla/plugins $pkgdir/usr/lib/$pkgname/browser/plugins
- ln -sf /usr/lib/mozilla/searchplugins $pkgdir/usr/lib/$pkgname/browser/searchplugins
-
- # We don't want the development stuff
- rm -rf $pkgdir/usr/{include,lib/$pkgname-devel,share/idl}
-
- # Workaround for now: https://bugzilla.mozilla.org/show_bug.cgi?id=658850
- ln -sf $pkgname $pkgdir/usr/lib/$pkgname/$pkgname-bin
+ install -Dm644 "$brandingdir/content/icon64.png" \
+ "$icondir/64x64/apps/$pkgname.png"
+ install -Dm644 "$brandingdir/mozicon128.png" \
+ "$icondir/128x128/apps/$pkgname.png"
+ install -Dm644 "$brandingdir/content/about-logo.png" \
+ "$icondir/192x192/apps/$pkgname.png"
+ install -Dm644 "$brandingdir/content/about-logo@2x.png" \
+ "$icondir/384x384/apps/$pkgname.png"
+
+ install -d "$pkgdir/usr/share/applications"
+ install -m644 "$srcdir/$pgname.desktop" \
+ "$pkgdir/usr/share/applications"
+
+ # Use system-provided dictionaries
+ rm -rf "$pkgdir/usr/lib/$pkgname/"{dictionaries,hyphenation}
+ ln -s /usr/share/hunspell "$pkgdir/usr/lib/$pkgname/dictionaries"
+ ln -s /usr/share/hyphen "$pkgdir/usr/lib/$pkgname/hyphenation"
+
+ rm -rf "$pkgdir/usr/lib/$pkgname/browser/"{searchplugins,plugins}
+ ln -sf /usr/lib/mozilla/plugins "$pkgdir/usr/lib/$pkgname/browser/plugins"
+ ln -sf /usr/lib/mozilla/searchplugins "$pkgdir/usr/lib/$pkgname/browser/searchplugins"
+
+ # Workaround for now:
+ #https://bugzilla.mozilla.org/show_bug.cgi?id=658850
+ ln -sf $pkgname "$pkgdir/usr/lib/$pkgname/$pkgname-bin"
}