summaryrefslogtreecommitdiff
path: root/libre/icecat/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Martí <mvdan@mvdan.cc>2013-03-03 20:08:26 +0100
committerDaniel Martí <mvdan@mvdan.cc>2013-03-03 20:08:26 +0100
commitb8abfa5c393d7fd7150a4aed1fb1e65dee85666d (patch)
tree0f980a9b4bc10650d5a65c744a58b81f8f49f804 /libre/icecat/PKGBUILD
parente162d50b2e66f37b84040498a251c30fcb9c7f84 (diff)
parentab8deffc6f4cadc2e90e841ceb0aa48493693425 (diff)
downloadabslibre-b8abfa5c393d7fd7150a4aed1fb1e65dee85666d.tar.gz
abslibre-b8abfa5c393d7fd7150a4aed1fb1e65dee85666d.tar.bz2
abslibre-b8abfa5c393d7fd7150a4aed1fb1e65dee85666d.zip
Merge http://projects.parabolagnulinux.org/abslibre
Diffstat (limited to 'libre/icecat/PKGBUILD')
-rw-r--r--libre/icecat/PKGBUILD28
1 files changed, 19 insertions, 9 deletions
diff --git a/libre/icecat/PKGBUILD b/libre/icecat/PKGBUILD
index 5f0a03e70..6898105d8 100644
--- a/libre/icecat/PKGBUILD
+++ b/libre/icecat/PKGBUILD
@@ -16,10 +16,10 @@
_pgo=false
pkgname=icecat
pkgver=17.0.1
-pkgrel=5
-pkgdesc='The GNUzilla web browser, based on Mozilla Firefox. SafeBrowsing and other Google services disabled!'
+pkgrel=7
+pkgdesc='GNU IceCat, the standalone web browser based on Mozilla Firefox.'
arch=(i686 x86_64 mips64el)
-license=(GPL2 MPL LGPL)
+license=(MPL GPL LGPL)
depends=(
alsa-lib
dbus-glib
@@ -76,10 +76,10 @@ source=(
)
md5sums=(
c88a29aa92fc41a07e777a0e63ac5f7e
- f6ade03013a0bcb7f1585c51cb488e81
- ac29b01c189f20abae2f3eef1618ffc0
+ 2a35cf0054d0459993e3c3bae3d9841d
+ dfeb4ab2c96aae3356a4c347eee0b97b
3009b176cc5f9b1e416b1bf7c45b064b
- fcd2d895a0335c1b5fb652401e9da0d5
+ 1dec37a964098fb3bc46bc767a5c0587
b41f82994fa056ffa5f8e6d99570e27a
b30ba2b5562558d510fdd09d626d0faa
64826fcf48816b13090042eefddbaa58
@@ -88,10 +88,22 @@ md5sums=(
)
build() {
+ # WebRTC build tries to execute "python" and expects Python 2
+ # Workaround taken from chromium PKGBUILD on Archlinux
+ mkdir "$srcdir/python2-path"
+ ln -s /usr/bin/python2 "$srcdir/python2-path/python"
+ export PATH="$srcdir/python2-path:$PATH"
+
+ export LDFLAGS="$LDFLAGS -Wl,-rpath,/usr/lib/$pkgname"
+ export PYTHON="/usr/bin/python2"
+ export MOZ_MAKE_FLAGS="$MAKEFLAGS"
+ unset MAKEFLAGS
+
mv $pkgname-$pkgver $srcdir/gnuzilla-build
cd $srcdir/gnuzilla-build
cp $srcdir/mozconfig .mozconfig # Load our build config, disable SafeSearch
+
if $_pgo; then
cat $srcdir/mozconfig.pgo >> .mozconfig
fi
@@ -108,7 +120,7 @@ build() {
sed -i '/^PRE_RELEASE_SUFFIX := ""/s/ ""//' \
browser/base/Makefile.in
- # This is a bug, we should fix it.
+ # This is a bug, we should fix it
if [ $CARCH = mips64el ]; then
# Fix MIPS N32 support.
sed -i 's/defined(_ABIO32)/(defined(_ABIO32) || defined(_ABIN32))/' \
@@ -123,8 +135,6 @@ build() {
fi
chmod +x build/unix/run-icecat.sh # fix bug for bad file permition
- export LDFLAGS="$LDFLAGS -Wl,-rpath,/usr/lib/$pkgname"
- export PYTHON=/usr/bin/python2
if $_pgo; then
LD_PRELOAD="" /usr/bin/Xvfb -nolisten tcp -extension GLX -screen 0 1280x1024x24 :99 &