summaryrefslogtreecommitdiff
path: root/libre/icecat/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2019-03-06 09:04:36 +0100
committerAndreas Grapentin <andreas@grapentin.org>2019-03-06 09:06:48 +0100
commit9aeb76d27282889923e9fbbd3349e795f79a4728 (patch)
tree011f2c32dc821ddc9ff3a88dc4344051908922e2 /libre/icecat/PKGBUILD
parent647880087e3ba3abb2b5efda3c42199d2f128222 (diff)
downloadabslibre-9aeb76d27282889923e9fbbd3349e795f79a4728.tar.gz
abslibre-9aeb76d27282889923e9fbbd3349e795f79a4728.tar.bz2
abslibre-9aeb76d27282889923e9fbbd3349e795f79a4728.zip
libre/icecat: rebuilt
Diffstat (limited to 'libre/icecat/PKGBUILD')
-rw-r--r--libre/icecat/PKGBUILD92
1 files changed, 59 insertions, 33 deletions
diff --git a/libre/icecat/PKGBUILD b/libre/icecat/PKGBUILD
index 80ad3d4a0..7edbcceac 100644
--- a/libre/icecat/PKGBUILD
+++ b/libre/icecat/PKGBUILD
@@ -17,29 +17,35 @@
pkgname=icecat
_pkgver=60.3.0-gnu1
pkgver=${_pkgver//-/_}
-pkgrel=2
+pkgrel=3
pkgdesc="GNU IceCat - a libre standalone web browser based on Mozilla Firefox."
arch=(x86_64 i686 armv7h)
license=(MPL GPL LGPL)
url="http://www.gnu.org/software/gnuzilla/"
-depends=(gtk3 gtk2 mozilla-common libxt startup-notification mime-types dbus-glib ffmpeg
- nss hunspell-en_US sqlite ttf-font libpulse libvpx icu)
-makedepends=(unzip zip diffutils python2 yasm mesa imake gconf inetutils xorg-server-xvfb
- autoconf2.13 rust clang llvm jack mozilla-searchplugins)
+depends=(gtk3 mozilla-common libxt startup-notification mime-types dbus-glib
+ ffmpeg nss ttf-font libpulse sqlite libvpx icu)
+makedepends=(unzip zip diffutils python2-setuptools yasm mesa imake inetutils
+ xorg-server-xvfb autoconf2.13 rust clang llvm jack gtk2
+ mozilla-searchplugins)
optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration'
'pulseaudio: Audio support'
- 'speech-dispatcher: Text-to-Speech')
-options=(!emptydirs !makeflags !strip)
+ 'speech-dispatcher: Text-to-Speech'
+ 'hunspell-en_US: Spell checking, American English')
+options=(!emptydirs !makeflags !debug)
source=(http://ftp.gnu.org/gnu/gnuzilla/${_pkgver%-*}/$pkgname-$_pkgver.tar.bz2{,.sig}
$pkgname.desktop
gnu_headshadow.png
- libre.patch)
+ libre-searchengines.patch
+ libre.patch
+ mozilla-1463035.patch)
sha256sums=('6145327092b4b195a4f63d0e86f4857eeba5607ffeb69b6f3bceb36e89a19645'
'SKIP'
'2f9d117c1524312fb45f3e953cb0de02c525fd385a9b2b6d47308c8aaab0aedd'
'93e3001ce152e1d142619e215a9ef07dd429943b99d21726c25da9ceb31e31cd'
- 'd32f97e812c536efd9bdc7043efd6f9472a1edd9f814b453805c7c10ffea25a6')
+ 'ec6bedc8e7af6db74ce57ea07fe34d266af0280d8d7b46387e6cf5a27c1e6ca7'
+ '6057f40b2a35a0ad01faa810d8cd41d6c22bddc8ae32e883e68b9fc543e4c92d'
+ '6c3781e13d3e8343aa2435bdb78d2e2666891154c7abd847388e5331e0424edb')
validpgpkeys=('A57369A8BABC2542B5A0368C3C76EED7D7E04784') # Ruben Rodriguez
prepare() {
@@ -60,66 +66,86 @@ ac_add_options --enable-optimize
ac_add_options --enable-rust-simd
# Branding
+ac_add_options --with-app-basename=icecat
+ac_add_options --with-app-name=icecat
ac_add_options --enable-official-branding
+ac_add_options --enable-update-channel=release
ac_add_options --with-distribution-id=org.gnu
# System libraries
-ac_add_options --with-system-zlib
+ac_add_options --enable-system-ffi
+ac_add_options --enable-system-sqlite
ac_add_options --with-system-bz2
ac_add_options --with-system-icu
ac_add_options --with-system-jpeg
ac_add_options --with-system-libvpx
ac_add_options --with-system-nspr
ac_add_options --with-system-nss
-ac_add_options --enable-system-sqlite
-ac_add_options --enable-system-ffi
+ac_add_options --with-system-zlib
# Features
ac_add_options --enable-alsa
+ac_add_options --enable-jack
ac_add_options --enable-startup-notification
ac_add_options --disable-crashreporter
+ac_add_options --disable-gconf
ac_add_options --disable-updater
-ac_add_options --disable-debug-symbols
-ac_add_options --disable-tests
ac_add_options --disable-eme
-ac_add_options --disable-gconf
-
-ac_add_options --with-app-basename=icecat
-ac_add_options --with-app-name=icecat
-ac_add_options --enable-update-channel=release
END
- if [[ "$CARCH" == arm* ]]; then
- sed -i \
- -e '/enable-gold/s/^/#/' \
- -e '/enable-pie/s/^/#/' \
- -e '/enable-optimize/d' \
- .mozconfig
+ if [[ $CARCH = arm* ]]; then
+ sed -i '/--enable-linker=gold/d' .mozconfig
+ sed -i '/--enable-rust-simd/d' .mozconfig
- cat >> .mozconfig << END
-ac_add_options --disable-webrtc
-ac_add_options --disable-elf-hack
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1463035
+ patch -Np1 -i "$srcdir"/mozilla-1463035.patch
+
+ cat >> .mozconfig <<END
ac_add_options --enable-optimize="-g -O2 -fno-schedule-insns"
+ac_add_options --disable-elf-hack
+ac_add_options --disable-webrtc
+ac_add_options --disable-av1
END
fi
+ if [[ $CARCH = i686 ]]; then
+ sed -i '/--enable-linker=gold/d' .mozconfig
+ fi
+
# Put gnu_headshadow.png in the source code
- # install -m644 "$srcdir/gnu_headshadow.png" \
- # browser/base/content/abouthome
+ install -m644 "$srcdir/gnu_headshadow.png" \
+ browser/base/content/abouthome
# Patch and remove anything that's left
- # patch -Np1 -i "$srcdir/libre.patch"
+ patch -Np1 -i "$srcdir/libre.patch"
+
# rm -v browser/base/content/abouthome/snippet*.png || true
# sed -i '\|abouthome/snippet|d
# ' browser/base/jar.mn
# Load our searchplugins
- # rm -rf -- browser/locales/searchplugins
- # cp -aT -- /usr/lib/mozilla/searchplugins browser/locales/searchplugins
+ rm -r -- browser/locales/searchplugins
+ cp -aT -- /usr/lib/mozilla/searchplugins browser/locales/searchplugins
+ patch -Np1 -i "$srcdir/libre-searchengines.patch"
}
build() {
cd "$srcdir/$pkgname-${pkgver%_*}"
+ export MOZ_NOSPAM=1
+ export MOZBUILD_STATE_PATH="$srcdir/mozbuild"
+
+ if [[ $CARCH = armv7h ]]; then
+ export RUSTFLAGS+=" -Cdebuginfo=0 -Clto=off"
+ export LDFLAGS+=" -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
+ fi
+
+ if [[ $CARCH = i686 ]]; then
+ export RUSTFLAGS+=" -Cdebuginfo=0 -Clto=off"
+ export LDFLAGS+=" -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
+ fi
+
+ # LTO needs more open files
+ ulimit -n 4096
./mach build
./mach buildsymbols