summaryrefslogtreecommitdiff
path: root/libre/icecat/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2017-06-29 10:24:30 +0200
committerAndreas Grapentin <andreas@grapentin.org>2017-06-29 10:25:05 +0200
commit492493721754842a899c2f22859970a2f454d47b (patch)
tree3fc2ea03464a086c9f3b985e55f1c4b5c11ca178 /libre/icecat/PKGBUILD
parentb4d7c49f5257fd9f781319e70964f9fe3d0b8906 (diff)
downloadabslibre-492493721754842a899c2f22859970a2f454d47b.tar.gz
abslibre-492493721754842a899c2f22859970a2f454d47b.tar.bz2
abslibre-492493721754842a899c2f22859970a2f454d47b.zip
libre/icecat: updated build for updated libeevent
Diffstat (limited to 'libre/icecat/PKGBUILD')
-rw-r--r--libre/icecat/PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/libre/icecat/PKGBUILD b/libre/icecat/PKGBUILD
index 0d796640a..1b01e7d9c 100644
--- a/libre/icecat/PKGBUILD
+++ b/libre/icecat/PKGBUILD
@@ -16,12 +16,12 @@ _pgo=false
pkgname=icecat
_pkgver=52.1.0-gnu1
pkgver=${_pkgver//-/_}
-pkgrel=1
+pkgrel=2
pkgdesc="GNU IceCat, the standalone web browser based on Mozilla Firefox."
arch=(i686 x86_64 armv7h)
license=(MPL GPL LGPL)
-depends=(alsa-lib dbus-glib desktop-file-utils ffmpeg gtk2 gtk3 hicolor-icon-theme hunspell icu=59.1 libevent libvpx libxt mime-types mozilla-common nss sqlite startup-notification ttf-font)
+depends=(alsa-lib dbus-glib desktop-file-utils ffmpeg gtk2 gtk3 hicolor-icon-theme hunspell icu=59.1 libvpx libxt mime-types mozilla-common nss sqlite startup-notification ttf-font)
makedepends=(autoconf2.13 diffutils gconf imake inetutils libpulse mesa mozilla-searchplugins python2 unzip yasm zip)
options=(!emptydirs !makeflags debug)
if $_pgo; then
@@ -43,10 +43,11 @@ source=(http://ftp.gnu.org/gnu/gnuzilla/${_pkgver%-*}/$pkgname-$_pkgver.tar.bz2{
$pkgname-fixed-loading-icon.png
disable-crypto-hardening-settings.patch
disable-spoofSource-referer.patch
+ no-crmf.patch
no-neon.patch)
sha256sums=('0beff2a04fdc1b56d274133cd22ff546fd609c929954132ff6bf1b800a5b24f3'
'SKIP'
- '88f14b86e4f2cd0772415365463514ce381c1081d8ac965c4181607c27595bf9'
+ '04952e0910c7c0d24faaa1ffa486dc3dae9f2c52548ff977858bec08ccb400f3'
'76a657a90371e637e7c4b371b71a15c85acafcece6277455e9ede84ffe104d3e'
'93e3001ce152e1d142619e215a9ef07dd429943b99d21726c25da9ceb31e31cd'
'52df9ffeb52166ed4abd9a132ee4a9017b9c4980f0725ba383610ccfb06d4745'
@@ -55,6 +56,7 @@ sha256sums=('0beff2a04fdc1b56d274133cd22ff546fd609c929954132ff6bf1b800a5b24f3'
'68e3a5b47c6d175cc95b98b069a15205f027cab83af9e075818d38610feb6213'
'0166aa368420f0bf0aab064b2188e3d852b241efeeb27dee66df2bc15e84b83a'
'c50043266e69f5844e6dce9ea7193af79587dcaa66806932d7867281a176f03e'
+ 'cf224d69e89f37f92202061669014b99fbf7b1fec38fd8ba9f957711fa095729'
'6d0c1c9ca28b20d206ce24ca84f4d4e3f5d062a2e9cb7445fcb6c2cfea959b4a')
validpgpkeys=(
'A57369A8BABC2542B5A0368C3C76EED7D7E04784' # Ruben Rodriguez
@@ -109,6 +111,9 @@ prepare() {
# https://labs.parabola.nu/issues/1073
patch -Np1 -i "$srcdir/disable-spoofSource-referer.patch"
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1371991
+ patch -Np1 -i "$srcdir/no-crmf.patch"
+
# ARM-specific changes:
if [[ "$CARCH" == arm* ]]; then
sed -i '/ac_add_options --enable-rust/d' .mozconfig