summaryrefslogtreecommitdiff
path: root/libre/iceape/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2016-12-25 10:31:37 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2016-12-25 10:32:54 -0300
commit99fcac2922b36501fb65ef4e96cf2f2f6d3cb056 (patch)
tree68220e53fa0da81c949f07f31d88fbd17f6f6e39 /libre/iceape/PKGBUILD
parent3286eb96ad0242486bf84586e8cee45cd7a32cd8 (diff)
downloadabslibre-99fcac2922b36501fb65ef4e96cf2f2f6d3cb056.tar.gz
abslibre-99fcac2922b36501fb65ef4e96cf2f2f6d3cb056.tar.bz2
abslibre-99fcac2922b36501fb65ef4e96cf2f2f6d3cb056.zip
iceape-1:2.46-1: updating version
Diffstat (limited to 'libre/iceape/PKGBUILD')
-rw-r--r--libre/iceape/PKGBUILD33
1 files changed, 16 insertions, 17 deletions
diff --git a/libre/iceape/PKGBUILD b/libre/iceape/PKGBUILD
index 306e5cc2f..356e6deb0 100644
--- a/libre/iceape/PKGBUILD
+++ b/libre/iceape/PKGBUILD
@@ -7,12 +7,12 @@ pkgname=iceape
epoch=1
_brandingver=2.39
_brandingrel=3
-pkgver=2.40
-pkgrel=5
+pkgver=2.46
+pkgrel=1
pkgdesc="A libre version of Debian Iceape, the internet suite based on SeaMonkey."
arch=(i686 x86_64 armv7h)
license=(MPL GPL LGPL)
-depends=(alsa-lib dbus-glib desktop-file-utils gtk2 hunspell libevent libnotify libvpx=1.6.0 libxt mime-types mozilla-common mozilla-searchplugins nss sqlite startup-notification libpulse icu=58.2 gconf)
+depends=(alsa-lib dbus-glib desktop-file-utils gtk2 gtk3 hunspell libevent libnotify libvpx=1.6.0 libxt mime-types mozilla-common mozilla-searchplugins nss sqlite startup-notification libpulse icu=58.2 gconf)
makedepends=(unzip zip pkg-config python2 librsvg-stable wireless_tools yasm mesa autoconf2.13 quilt imake python3 gst-plugins-base)
optdepends=('gst-plugins-base: vorbis decoding, ogg demuxing'
'gst-plugins-bad: aac, vp8 and opus decoding'
@@ -31,23 +31,25 @@ source=("https://archive.mozilla.org/pub/mozilla.org/$_pkgname/releases/$pkgver/
$pkgname-2.0-lang.patch
libre.patch
rhbz-966424.patch
- mozilla-1245076.patch
- mozilla-1245076-1.patch)
-sha256sums=('7ecccc039d03f38d197b123b59ea42eac4c0c10e4bdec779b3665d79b435fa01'
+ xulrunner-27.0-build-arm.patch)
+sha256sums=('39c84ce6fa1ed7c30152473e0dcd858df07437e84b29e5a18973db437a28a912'
'ed6f0aab804235a8ea32631b8d8d664329e9507f7aa6fb016c87042bace51a44'
'SKIP'
- 'b1e2b82e1c5c9b967b40b651e5fa7f3d79b71081337c5263a9ad454d0abaf056'
+ 'cbc768322c5f3cc9c43594618826349c14d902ba7756d6c16c1d33430d058d3b'
'46ac418fe26937460a36a593d71c8f5cef1288c9e747cac4ec4ca92db56da45d'
'ab19d10fbd6258aec37ab5e5efb12429814b2c24a1193284a48dd654311b4e2e'
- 'bc5150486aea78f58216597257500f14a83a2500eb96f41a2090f13785fb92bb'
+ '8055e44151f007dd176d2bc545aa3ce282e9b1a59b35ca1f9f93d1c3e21689cd'
'746cb474c5a2c26fc474256e430e035e604b71b27df1003d4af85018fa263f4a'
- '05574c7d0f259da161bcd0e2e8bc9a19401e620ff29439da935d349eebb60efa'
- '6e7cba25c52b246da183b8309e7b56208bd991d1a7adb40063c5702a6f3722ea')
+ 'bc83b8a51c81a401da2fbe1f7cd0843248c32607d3a51119585df074d797922e')
validpgpkeys=(
'C92BAA713B8D53D3CAE63FC9E6974752F9704456' # André Silva
'684D54A189305A9CC95446D36B888913DDB59515' # Márcio Silva
)
+if [[ "$CARCH" == arm* ]]; then
+ highmem=1
+fi
+
prepare() {
cd "$_pkgname-$pkgver"
@@ -118,7 +120,7 @@ prepare() {
cp "${srcdir}/mozconfig" .mozconfig
# FS#48404
- echo "ac_add_options --enable-gstreamer=1.0" >> .mozconfig
+ #echo "ac_add_options --enable-gstreamer=1.0" >> .mozconfig
# https://bugs.archlinux.org/task/41689
patch -Np1 -d mozilla -i "$srcdir/rhbz-966424.patch"
@@ -133,17 +135,14 @@ prepare() {
# 2.26 build fix from wgnie (blfs ch 37)
sed -i 's/$(MOZ_ZLIB_CFLAGS)/& $(MOZ_PIXMAN_CFLAGS)/' config/config.mk
- # GCC 6
- patch -Np1 -d mozilla -i ../../mozilla-1245076.patch
- patch -Np1 -d mozilla -i ../../mozilla-1245076-1.patch
-
# ARM-specific changes
if [[ "$CARCH" == arm* ]]; then
cat >> .mozconfig <<- EOF
ac_add_options --disable-elf-hack
- ac_add_options --disable-neon
- ac_add_options --disable-ion
EOF
+
+ LDFLAGS+=" -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
+ patch -p2 -d mozilla -i "$srcdir/xulrunner-27.0-build-arm.patch"
fi
}