summaryrefslogtreecommitdiff
path: root/libre/hplip/PKGBUILD
diff options
context:
space:
mode:
authorDavid P <megver83@parabola.nu>2019-12-27 16:44:44 -0300
committerDavid P <megver83@parabola.nu>2019-12-27 16:44:44 -0300
commit8067374d02616d5d14bb7f1b0a97852eb1cf3b76 (patch)
tree0016bd54b36291dee4fd0ef01c4e325c3bb8b580 /libre/hplip/PKGBUILD
parent92f9d0dcbb5c9a6a8606a40e5e68485636a86a77 (diff)
downloadabslibre-8067374d02616d5d14bb7f1b0a97852eb1cf3b76.tar.gz
abslibre-8067374d02616d5d14bb7f1b0a97852eb1cf3b76.tar.bz2
abslibre-8067374d02616d5d14bb7f1b0a97852eb1cf3b76.zip
updpkg: libre/hplip 1:3.19.12-1.par1
Signed-off-by: David P <megver83@parabola.nu>
Diffstat (limited to 'libre/hplip/PKGBUILD')
-rw-r--r--libre/hplip/PKGBUILD34
1 files changed, 20 insertions, 14 deletions
diff --git a/libre/hplip/PKGBUILD b/libre/hplip/PKGBUILD
index e3f222464..256b8cca4 100644
--- a/libre/hplip/PKGBUILD
+++ b/libre/hplip/PKGBUILD
@@ -8,7 +8,7 @@
# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
pkgname=hplip
-pkgver=3.19.6
+pkgver=3.19.12
pkgrel=1
pkgrel+=.par1
epoch=1
@@ -18,7 +18,7 @@ arch=('x86_64')
arch+=('i686' 'armv7h')
url="https://hplipopensource.com"
license=('GPL' 'custom')
-depends=('python-dbus' 'ghostscript' 'net-snmp' 'foomatic-db-engine' 'python-gobject')
+depends=('python-dbus' 'python-distro' 'ghostscript' 'net-snmp' 'foomatic-db-engine' 'python-gobject')
makedepends=('python-pyqt5' 'sane' 'rpcbind' 'cups' 'libusb')
optdepends=('cups: for printing support'
'sane: for scanner support'
@@ -36,17 +36,19 @@ source=(https://downloads.sourceforge.net/${pkgname}/$pkgname-$pkgver.tar.gz{,.a
disable_upgrade.patch
0022-Add-include-cups-ppd.h-in-various-places-as-CUPS-2.2.patch
0023-Fix-handling-of-unicode-filenames-in-sixext.py.patch
- 0025-Remove-all-ImageProcessor-functionality-which-is-clo.patch)
-sha512sums=('c99448ad0cef9fc626a0a03147a0d582513cb838ecfbfe29f07c65bbf701dee5c7d02222469b118ccc4e8c230c7a4b4685a72a1e67595ee01150b0472692d654'
+ 0025-Remove-all-ImageProcessor-functionality-which-is-clo.patch
+ python3.diff)
+sha512sums=('5552cd717ae082ee55cdb77d79e8d035d8ecb7cf23c79d659fda43468d8ed414a33c4d869eab4ab83dee836f0d1cceb74c3c4a249e26f904a5ab2350e08a5677'
'SKIP'
'f0cf2774e53070406e89614b748e3c45079be889b83d5854340b92093643f6f8b332d6b6e617884d2bdcbef667a84ee5741b07c5fb080bb04925bb454af448d1'
'22aeb5b851f78bc6bc62e0bc3da99fecaf42d7604af41e2f3343f8d3666541f7b06b7d1a7d0ddf24f1731ac7b12dfe582375a98e3b94dfa323d6ce954549ca67'
'763949a0bc460dcc9faefc86f2a91cf342781bfce696ed0c3826758572dd03ac266bbeb7b6a4f9376ac298d7d3c9c4def42d94921a8e1d1695e39396e36d95ff'
- '8710e039626878270b8b7bc1569566274d935c84652d758e25ce8fe01c0f44d911148620bb494489e1238201c01f3ba255c19f7dc5c2ff0d45a5f2a79190286b')
+ '8710e039626878270b8b7bc1569566274d935c84652d758e25ce8fe01c0f44d911148620bb494489e1238201c01f3ba255c19f7dc5c2ff0d45a5f2a79190286b'
+ '5885b223f96706bc09a147b5c141d620846c9058563e986983ca2ab90922cabe891a651d90d5004d45549b3874c40f8a1570a8a79e067d66f1826681111c7e82')
validpgpkeys=('4ABA2F66DBD5A95894910E0673D770CDA59047B9') # HPLIP <hplip@hp.com>
prepare() {
- cd $pkgname-$pkgver
+ cd "$pkgname"-$pkgver
echo "Removing printers not supported with free drivers from the database"
@@ -74,21 +76,25 @@ prepare() {
echo "Preparing source"
# disable insecure update - https://bugs.archlinux.org/task/38083
- patch -Np0 -i ${srcdir}/disable_upgrade.patch
+ patch -Np0 -i "${srcdir}"/disable_upgrade.patch
# add missing 'include <cups/ppd.h>' at various places
- patch -Np1 -i ${srcdir}/0022-Add-include-cups-ppd.h-in-various-places-as-CUPS-2.2.patch
+ patch -Np1 -i "${srcdir}"/0022-Add-include-cups-ppd.h-in-various-places-as-CUPS-2.2.patch
# fix some handling unicode file names FS#58412
- patch -Np1 -i ${srcdir}/0023-Fix-handling-of-unicode-filenames-in-sixext.py.patch
+ patch -Np1 -i "${srcdir}"/0023-Fix-handling-of-unicode-filenames-in-sixext.py.patch
# remove binary blob libImageProcessor and all linking - FS#59681
- patch -Np1 -i ${srcdir}/0025-Remove-all-ImageProcessor-functionality-which-is-clo.patch
+ patch -Np1 -i "${srcdir}"/0025-Remove-all-ImageProcessor-functionality-which-is-clo.patch
+ # Workaround patch for missing Python3 transition of the old
+ # (pre-USB-storage) photo memory card support (pcardext) - Debian patch
+ patch -Np1 -i "${srcdir}"/python3.diff
export AUTOMAKE='automake --foreign'
autoreconf --force --install
}
build() {
- cd $pkgname-$pkgver
+ cd "$pkgname"-$pkgver
+ export CFLAGS+=" $(python3-config --includes)" # Fix build with python 3.8
./configure --prefix=/usr \
--enable-qt5 \
--disable-qt4 \
@@ -99,13 +105,13 @@ build() {
}
package() {
- cd $pkgname-$pkgver
+ cd "$pkgname"-$pkgver
make -j1 rulesdir=/usr/lib/udev/rules.d DESTDIR="$pkgdir/" install
# remove config provided by sane and autostart of hp-daemon
rm -rf "$pkgdir"/etc/{sane.d,xdg}
- install -dm755 ${pkgdir}/etc/sane.d/dll.d
- echo hpaio > ${pkgdir}/etc/sane.d/dll.d/hpaio
+ install -dm755 "${pkgdir}"/etc/sane.d/dll.d
+ echo hpaio > "${pkgdir}"/etc/sane.d/dll.d/hpaio
# remove HAL .fdi file because HAL is no longer used
rm -vrf "$pkgdir"/usr/share/hal