summaryrefslogtreecommitdiff
path: root/libre/hplip/PKGBUILD
diff options
context:
space:
mode:
authorOmar Vega Ramos <ovruni@gnu.org.pe>2018-09-04 14:04:25 -0500
committerOmar Vega Ramos <ovruni@gnu.org.pe>2018-09-04 14:04:25 -0500
commit86730d095a36076d7d785f51b0fb65d05c097d0b (patch)
tree95155a52743b9d1b68494b3a81141cf9732fa737 /libre/hplip/PKGBUILD
parentbbf64929616d49e2d9396ed9144d3b4fe7c3be65 (diff)
downloadabslibre-86730d095a36076d7d785f51b0fb65d05c097d0b.tar.gz
abslibre-86730d095a36076d7d785f51b0fb65d05c097d0b.tar.bz2
abslibre-86730d095a36076d7d785f51b0fb65d05c097d0b.zip
hplip-1:3.18.6-1.parabola1: updating version
Diffstat (limited to 'libre/hplip/PKGBUILD')
-rw-r--r--libre/hplip/PKGBUILD26
1 files changed, 21 insertions, 5 deletions
diff --git a/libre/hplip/PKGBUILD b/libre/hplip/PKGBUILD
index 123cd4518..67be94d20 100644
--- a/libre/hplip/PKGBUILD
+++ b/libre/hplip/PKGBUILD
@@ -9,12 +9,13 @@
# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
pkgname=hplip
-pkgver=3.17.11
+pkgver=3.18.6
pkgrel=1.parabola1
+epoch=1
pkgdesc="Drivers for HP DeskJet, OfficeJet, Photosmart, Business Inkjet and some LaserJet, without printers with nonfree drivers support and hplip-plugin binary blobs recommendation (Parabola rebranded)"
arch=('i686' 'x86_64' 'armv7h')
url="http://hplipopensource.com"
-license=('GPL')
+license=('GPL' 'custom')
depends=('python-dbus' 'ghostscript' 'net-snmp' 'foomatic-db-engine')
makedepends=('python-pyqt5' 'python-gobject' 'sane' 'rpcbind' 'cups' 'libusb')
optdepends=('cups: for printing support'
@@ -32,11 +33,17 @@ conflicts=(${pkgname}-libre)
backup=('etc/hp/hplip.conf' 'etc/sane.d/dll.d/hpaio')
source=(https://downloads.sourceforge.net/${pkgname}/$pkgname-$pkgver.tar.gz{,.asc}
disable_upgrade.patch
- 0022-Add-include-cups-ppd.h-in-various-places-as-CUPS-2.2.patch)
-sha256sums=('2f91be9489a50e4c929b2b9d3c72c09905c1195f9b360568b07fcbde4f3faa75'
+ 0022-Add-include-cups-ppd.h-in-various-places-as-CUPS-2.2.patch
+ 0023-Fix-handling-of-unicode-filenames-in-sixext.py.patch
+ fix_install.patch
+ python.patch)
+sha256sums=('0ecf3e68b09480f602de81798ac00774cf8ffe754692e784bbbe0f9b2e337b7d'
'SKIP'
'eca366677583122f2e1048103f0d4a2b002a18c1e6d17b0bc71f4067a221fd38'
- 'a5ee6546d33db8f41ecea2b377355ce261b3e98d7f9988ee1652f0daebb6d0da')
+ 'a5ee6546d33db8f41ecea2b377355ce261b3e98d7f9988ee1652f0daebb6d0da'
+ '85cd7fa2314f217cf8072a2635bff82831564f842dba245e0619e0630a8fc0f5'
+ '6edaedfd3f0925b099632a7052e054f18549be25381689680e8374c869687dc6'
+ '7116e9bb1bd9a01b6638dd705671f6e12076b143757edff3273c1cf89a1bbdd1')
validpgpkeys=('4ABA2F66DBD5A95894910E0673D770CDA59047B9') # HPLIP <hplip@hp.com>
prepare() {
@@ -72,6 +79,12 @@ prepare() {
# add missing 'include <cups/ppd.h>' at various places
patch -Np1 -i ${srcdir}/0022-Add-include-cups-ppd.h-in-various-places-as-CUPS-2.2.patch
+ # fix some handling unicode file names FS#58412
+ patch -Np1 -i ${srcdir}/0023-Fix-handling-of-unicode-filenames-in-sixext.py.patch
+ # fix installation of missing library - FS#59548
+# patch -Np1 -i ${srcdir}/fix_install.patch
+ # fix python issue - FS#59548
+# patch -Np1 -i ${srcdir}/python.patch
export AUTOMAKE='automake --foreign'
autoreconf --force --install
@@ -102,4 +115,7 @@ package() {
# remove rc script
rm -vrf "$pkgdir"/etc/init.d
+
+ # add mixed license file
+ install -Dt "${pkgdir}"/usr/share/licenses/${pkgname} -m644 COPYING
}