summaryrefslogtreecommitdiff
path: root/libre/hexchat/PKGBUILD
diff options
context:
space:
mode:
authorOmar Vega Ramos <ovruni@gnu.org.pe>2020-01-04 22:18:56 -0500
committerOmar Vega Ramos <ovruni@gnu.org.pe>2020-01-04 22:18:56 -0500
commit52702508fd58367865a089ce04d4b9e6798e63a6 (patch)
tree2a88d04830774178afd00212ecfc4758ab1edcb0 /libre/hexchat/PKGBUILD
parent6a56e1d68ac3f419b4b7bad467504b9e44f266bf (diff)
downloadabslibre-52702508fd58367865a089ce04d4b9e6798e63a6.tar.gz
abslibre-52702508fd58367865a089ce04d4b9e6798e63a6.tar.bz2
abslibre-52702508fd58367865a089ce04d4b9e6798e63a6.zip
hexchat-2.14.3-1.parabola1: updating version
Diffstat (limited to 'libre/hexchat/PKGBUILD')
-rw-r--r--libre/hexchat/PKGBUILD41
1 files changed, 20 insertions, 21 deletions
diff --git a/libre/hexchat/PKGBUILD b/libre/hexchat/PKGBUILD
index 39b552378..36b9e30f9 100644
--- a/libre/hexchat/PKGBUILD
+++ b/libre/hexchat/PKGBUILD
@@ -1,39 +1,38 @@
-# $Id$
# Maintainer (Arch): Maxime Gauduin <alucryd@archlinux.org>
# Contributor (Arch): TingPing <tingping@tingping.se>
# Contributor: André Silva <emulatorman@hyperbola.info>
# Maintainer: Freemor <freemor@freemor.ca>
pkgname=hexchat
-pkgver=2.14.2.r9.ged553301
-pkgrel=1.parabola1
-pkgdesc='A popular and easy to use graphical IRC (chat) client, without nonfree browser reference'
-arch=('i686' 'x86_64' 'armv7h')
+pkgver=2.14.3
+pkgrel=1
+pkgrel+=.parabola1
+pkgdesc='A popular and easy to use graphical IRC (chat) client'
+pkgdesc+=', without nonfree browser reference'
+arch=('x86_64')
+arch+=('i686' 'armv7h')
url='https://hexchat.github.io/'
license=('GPL')
-
-depends=('gtk2' 'openssl' 'dbus-glib' 'lua' 'python-cffi'
- 'libcanberra' 'libnotify' 'libproxy' 'pciutils'
- 'hicolor-icon-theme' 'desktop-file-utils' 'sound-theme-freedesktop' 'iso-codes')
-makedepends=('git' 'perl' 'python' 'meson')
-optdepends=('enchant: for spell check'
- 'perl: for perl plugin'
- 'python: for python plugin')
+depends=('dbus-glib' 'desktop-file-utils' 'gdk-pixbuf2' 'glib2' 'gtk2'
+ 'libcanberra' 'libnotify' 'libproxy' 'openssl' 'pango' 'pciutils')
+makedepends=('git' 'intltool' 'iso-codes' 'lua' 'meson' 'perl' 'python-cffi')
+optdepends=('enchant: Spell check'
+ 'iso-codes: Display language names instead of codes'
+ 'lua: Lua plugin'
+ 'perl: Perl plugin'
+ 'python-cffi: Python plugin')
replaces=(${pkgname}-libre)
conflicts=(${pkgname}-libre)
-source=("git+https://github.com/hexchat/hexchat.git" 'restore_ctrl-w.patch')
+source=("git+https://github.com/hexchat/hexchat.git#tag=v${pkgver}"
+ '0002-python-3-8.patch'
+ 'restore_ctrl-w.patch')
sha256sums=('SKIP'
+ '8d17ce657e744272815b5fb33d8ad959f79ece3294349637eaadcf86d90496fa'
'f78f986a064e6c5a8713a219fa042c94bb2b0236869d33b48801faedc9cef63e')
-pkgver() {
- cd "hexchat"
-
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
-
prepare() {
cd hexchat
+ patch -Np1 < ../0002-python-3-8.patch
# Remove nonfree browser references
sed -i '\|NAME Open Link| s|Firefox|Iceweasel|' src/common/hexchat.c