summaryrefslogtreecommitdiff
path: root/libre/handbrake/PKGBUILD
diff options
context:
space:
mode:
authorOmar Vega Ramos <ovruni@gnu.org.pe>2015-12-12 06:09:12 -0500
committerOmar Vega Ramos <ovruni@gnu.org.pe>2015-12-12 06:09:12 -0500
commit76974e24e13a6007a501f5c708997ade26f1ff3d (patch)
tree7118a5adf05befeeb58d0fbf2cd72570515351d9 /libre/handbrake/PKGBUILD
parent44b995144f47ad26288ca1b0c53de31bb31edf22 (diff)
downloadabslibre-76974e24e13a6007a501f5c708997ade26f1ff3d.tar.gz
abslibre-76974e24e13a6007a501f5c708997ade26f1ff3d.tar.bz2
abslibre-76974e24e13a6007a501f5c708997ade26f1ff3d.zip
handbrake-0.10.2-4.parabola1: rebuild
Diffstat (limited to 'libre/handbrake/PKGBUILD')
-rw-r--r--libre/handbrake/PKGBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/libre/handbrake/PKGBUILD b/libre/handbrake/PKGBUILD
index cace5f357..3b401a70e 100644
--- a/libre/handbrake/PKGBUILD
+++ b/libre/handbrake/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=('handbrake' 'handbrake-cli')
pkgver=0.10.2
-pkgrel=3.parabola1
+pkgrel=4.parabola1
url="http://handbrake.fr/"
license=('GPL')
@@ -13,7 +13,8 @@ arch=('i686' 'x86_64' 'armv7h')
depends=('gcc-libs')
_gui_depends=('libnotify' 'dbus-glib' 'gtk3' 'gst-plugins-base')
makedepends=('intltool' 'python2' "${_gui_depends[@]}")
-source=(https://handbrake.fr/mirror/HandBrake-$pkgver.tar.bz2)
+source=(https://handbrake.fr/mirror/HandBrake-$pkgver.tar.bz2
+ libav-fix_libvpxenc.patch)
# HandBrake has a bunch of dependencies that may be either pacman
# packages, or built in the contrib/ directory as "modules". This is
@@ -62,15 +63,20 @@ makedepends+=('yasm') # module if FEATURE.local_yasm
depends+=("${_depends[@]#*:}")
source+=("${_modules[@]/#*:/http://download.handbrake.fr/handbrake/contrib/}")
-noextract+=("${_modules[@]#*:}")
+#noextract+=("${_modules[@]#*:}")
# Lock the specific version of libx264, as it changes often.
depends+=('libx264.so')
sha256sums=('4cc3828393b26a982dbe00febd700c5090d3443c1d45492e0b373e02da73c699'
+ 'fabf99d9492345af058c502e83b613b23f939c7f9092c9e80aa260b72cbed595'
'bc3807426d4e73fe8c245730b0df4ba95766cf7e17e47c738ee302f73d066ac9')
prepare() {
+ # Fixing libav
+ cd "$srcdir/libav-v10.1"
+ patch -Np1 -i ../libav-fix_libvpxenc.patch
+
cd "$srcdir/HandBrake-$pkgver"
local dep
@@ -83,11 +89,9 @@ prepare() {
done
echo 'TEST.GCC.l += fdk-aac x265' >> test/module.defs
- # Use the pre-downloaded files
+ # Use the libav patched
mkdir -p download
- for dep in "${_modules[@]}"; do
- ln -srf "${srcdir}/${dep[@]#*:}" download/
- done
+ bsdtar -cjf download/libav-v10.1.tar.bz2 -C .. libav-v10.1
}
build() {