summaryrefslogtreecommitdiff
path: root/libre/ghostscript/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2016-01-11 00:23:42 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2016-01-11 00:30:04 -0300
commitd4203d55982ed977c12ed9ee1d3502cc88a15e9c (patch)
tree0a8240800794fd7d1b44463b268da814570dc7ee /libre/ghostscript/PKGBUILD
parentae4ec4486387c1bf8c3edb471aed2200328005fb (diff)
downloadabslibre-d4203d55982ed977c12ed9ee1d3502cc88a15e9c.tar.gz
abslibre-d4203d55982ed977c12ed9ee1d3502cc88a15e9c.tar.bz2
abslibre-d4203d55982ed977c12ed9ee1d3502cc88a15e9c.zip
ghostscript-9.18-6.parabola1: fix use of system freetype to solve wrong glyphs; FS#46744 -> https://bugs.archlinux.org/task/46744
Diffstat (limited to 'libre/ghostscript/PKGBUILD')
-rw-r--r--libre/ghostscript/PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/libre/ghostscript/PKGBUILD b/libre/ghostscript/PKGBUILD
index 8da8dd93c..b272327b4 100644
--- a/libre/ghostscript/PKGBUILD
+++ b/libre/ghostscript/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 257535 2016-01-06 09:27:50Z andyrtr $
+# $Id: PKGBUILD 257646 2016-01-08 18:25:04Z andyrtr $
# Maintainer (Arch): AndyRTR <andyrtr@archlinux.org>
# Maintainer: André Silva <emulatorman@parabola.nu>
@@ -6,7 +6,7 @@
pkgname=ghostscript
pkgver=9.18
-pkgrel=5.parabola1
+pkgrel=6.parabola1
pkgdesc="An interpreter for the PostScript language, without nonfree JPEG XR support"
arch=('i686' 'x86_64')
license=('AGPL' 'custom')
@@ -23,6 +23,7 @@ source=(https://repo.parabola.nu/other/ghostscript-libre/ghostscript-libre-${pkg
ghostscript-sys-zlib.patch
bug_696246.diff
add_gserrors_h.diff
+ fix_check_for_using_shared_freetype_lib.diff
libre.patch)
#options=('!makeflags')
# http://downloads.ghostscript.com/public/SHA1SUMS
@@ -31,6 +32,7 @@ sha1sums=('6899da0407e4bf4a9f65848e68df237ed83c04ee'
'e054caf753df4d67221b29a2eac66130653f7556'
'f259eaac3beb0ec346bb2d4d2455e4e3baddecd4'
'ca686fed1af36d1f9fa866b47ff129c71d6a19ff'
+ '8258043b111832fe52989ccb00d6d87285fcad81'
'51f821faec00749ed8b61d772879269f9809f694')
mksource() {
cd ghostscript-${pkgver}
@@ -47,6 +49,9 @@ prepare() {
patch -Np1 -i ${srcdir}/bug_696246.diff
# add a missing header; FS#46928
patch -Np1 -i ${srcdir}/add_gserrors_h.diff
+ # fix use system freetype - FS#46744
+ # http://git.ghostscript.com/?p=ghostpdl.git;a=patch;h=8f5d28536e4518716fdfe974e580194c8f57871d
+ patch -Np1 -i ${srcdir}/fix_check_for_using_shared_freetype_lib.diff
# remove nonfree JPEG XR reference on the license file
patch -Np1 -i ${srcdir}/libre.patch
}
@@ -57,8 +62,7 @@ build() {
# force it to use system-libs
# keep heavily patched included openjpeg, leads to segfault with system openjpeg
# https://bugs.archlinux.org/task/38226
- #freetype # use internal one - FS#46744
- rm -rf jpeg libpng zlib jasper expat tiff lcms lcms2 cups/libs # jbig2dec is in community
+ rm -rf jpeg libpng zlib jasper expat tiff lcms lcms2 freetype cups/libs # jbig2dec is in community
autoconf --force