summaryrefslogtreecommitdiff
path: root/libre/ghostscript-libre/PKGBUILD
diff options
context:
space:
mode:
authorMárcio Alexandre Silva Delgado <coadde@lavabit.com>2013-02-06 11:55:48 -0200
committerMárcio Alexandre Silva Delgado <coadde@lavabit.com>2013-02-06 11:55:48 -0200
commitce15c219696194cd6826205cb630e64cfb9c1c5b (patch)
treed59fd775358e09bf90d842203d3f751c97b1f75a /libre/ghostscript-libre/PKGBUILD
parent387a6ac962ce6a21ccb27fa2cc494ea6e3d2b8cd (diff)
parentc1bff90faaaca75404032580f2ad5213ec76e893 (diff)
downloadabslibre-ce15c219696194cd6826205cb630e64cfb9c1c5b.tar.gz
abslibre-ce15c219696194cd6826205cb630e64cfb9c1c5b.tar.bz2
abslibre-ce15c219696194cd6826205cb630e64cfb9c1c5b.zip
Merge ssh://parabolagnulinux.org:1863/srv/git/abslibre
Diffstat (limited to 'libre/ghostscript-libre/PKGBUILD')
-rw-r--r--libre/ghostscript-libre/PKGBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/libre/ghostscript-libre/PKGBUILD b/libre/ghostscript-libre/PKGBUILD
index 656f49fb5..499f4bab0 100644
--- a/libre/ghostscript-libre/PKGBUILD
+++ b/libre/ghostscript-libre/PKGBUILD
@@ -6,7 +6,7 @@
_pkgname=ghostscript
pkgname=ghostscript-libre
pkgver=9.06
-pkgrel=1
+pkgrel=1.1 # rebuild for mips64el -march
pkgdesc="An interpreter for the PostScript language without non-free files"
arch=('i686' 'x86_64' 'mips64el')
license=('GPL3') #non free files removed
@@ -18,12 +18,17 @@ conflicts=('ghostscript')
replaces=('ghostscript')
provides=("ghostscript=$pkgver")
url="http://www.ghostscript.com/"
-source=(http://downloads.ghostscript.com/public/ghostscript-${pkgver}.tar.bz2)
-options=('!libtool' '!makeflags')
-md5sums=('46f9ebe40dc52755287b30704270db11')
+source=(http://downloads.ghostscript.com/public/ghostscript-${pkgver}.tar.bz2
+ ijs-automake.patch)
+options=('!libtool')
+md5sums=('46f9ebe40dc52755287b30704270db11'
+ '686830841eb9004143a0d0f56b73aaaf')
build() {
cd ${srcdir}/ghostscript-${pkgver}
+
+ # Fix build with recent automake.
+ patch -p1 -i "$srcdir/ijs-automake.patch"
# delete non-free packages
grep -l "are not altered" Resource/CMap/* | xargs rm -fv
@@ -57,7 +62,7 @@ build() {
package() {
cd ${srcdir}/ghostscript-${pkgver}
- make DESTDIR=${pkgdir} \
+ make -j1 DESTDIR=${pkgdir} \
cups_serverroot=${pkgdir}/etc/cups \
cups_serverbin=${pkgdir}/usr/lib/cups install soinstall
@@ -72,5 +77,5 @@ package() {
# install IJS
cd ${srcdir}/ghostscript-${pkgver}/ijs
- make DESTDIR=${pkgdir} install
+ make -j1 DESTDIR=${pkgdir} install
}