summaryrefslogtreecommitdiff
path: root/libre/file-roller-libre/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2013-10-07 17:12:13 -0200
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2013-10-07 17:12:13 -0200
commitd187db589e48a12b2c0cee781fa96c7240dab9c4 (patch)
tree6242ef9724164b3cb425ebf9a5764792860a46e4 /libre/file-roller-libre/PKGBUILD
parent29fd67bdbde521fb3f21678f5d724e84b1bbcab0 (diff)
downloadabslibre-d187db589e48a12b2c0cee781fa96c7240dab9c4.tar.gz
abslibre-d187db589e48a12b2c0cee781fa96c7240dab9c4.tar.bz2
abslibre-d187db589e48a12b2c0cee781fa96c7240dab9c4.zip
file-roller-libre-3.10.0-2: updating version
* add unar as dependency because p7zip-libre hasn't rar support
Diffstat (limited to 'libre/file-roller-libre/PKGBUILD')
-rw-r--r--libre/file-roller-libre/PKGBUILD29
1 files changed, 18 insertions, 11 deletions
diff --git a/libre/file-roller-libre/PKGBUILD b/libre/file-roller-libre/PKGBUILD
index 5c6865833..8289eb471 100644
--- a/libre/file-roller-libre/PKGBUILD
+++ b/libre/file-roller-libre/PKGBUILD
@@ -1,20 +1,17 @@
-# $Id: PKGBUILD 193443 2013-08-20 09:36:30Z jgc $
+# $Id: PKGBUILD 195293 2013-09-30 08:01:47Z jgc $
# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# Contributor: Jan de Groot <jgc@archlinux.org>
_pkgname=file-roller
pkgname=file-roller-libre
-pkgver=3.8.4
-pkgrel=1
-pkgdesc="Create and modify archives, with unar recommendation included and nonfree unace recommendation removed"
+pkgver=3.10.0
+pkgrel=2
+pkgdesc="Create and modify archives, with unar support included and nonfree unace recommendation removed"
arch=('i686' 'x86_64' 'mips64el')
license=('GPL')
-depends=('desktop-file-utils' 'gtk3' 'hicolor-icon-theme' 'dconf' 'libarchive' 'file' 'json-glib' 'libnotify')
+depends=('desktop-file-utils' 'gtk3' 'hicolor-icon-theme' 'dconf' 'libarchive' 'file' 'json-glib' 'libnotify' 'p7zip' 'unar')
makedepends=('intltool' 'gnome-doc-utils' 'pkg-config' 'libnautilus-extension' 'itstool' 'docbook-xsl')
-optdepends=('unar: the free RAR uncompression utility'
- 'zip: creates PKZIP-compatible .zip files'
- 'p7zip: 7zip compression utility'
- 'arj: ARJ archiver')
+optdepends=('lrzip: lrzip archive support')
groups=('gnome-extra')
provides=("$_pkgname=$pkgver")
replaces=("$_pkgname")
@@ -22,8 +19,18 @@ conflicts=("$_pkgname")
options=('!libtool' '!emptydirs')
install=file-roller.install
url="http://www.gnome.org"
-source=(http://ftp.gnome.org/pub/gnome/sources/$_pkgname/${pkgver::3}/$_pkgname-$pkgver.tar.xz)
-sha256sums=('3615bc41bbe28030d16ee414a8f5f9a3e37f745733c39032ef1559a06be3eea8')
+source=(http://ftp.gnome.org/pub/gnome/sources/$_pkgname/${pkgver%.*}/$_pkgname-$pkgver.tar.xz
+ bug708854.patch
+ bug709035.patch)
+sha256sums=('d889bb9904146e5715c082aa9a6d96b0606a066ba2bf05fbfb7030f2bf274f13'
+ 'a8f4e856924b6b78e47cc134c723d1d93119f90ec9ab69dd0b59ec8a934688ba'
+ '59f07968b720ccd9c70e6232b2bfcaa3cf9298d6ce48be4882154d69cbe7a909')
+
+prepare() {
+ cd $_pkgname-$pkgver
+ patch -Np1 -i ../bug708854.patch
+ patch -Np1 -i ../bug709035.patch
+}
build() {
cd $_pkgname-$pkgver