summaryrefslogtreecommitdiff
path: root/libre/faience-icon-theme/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-09-05 02:03:28 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-09-05 02:03:28 -0300
commit288a48d376f96b670f699dc321ec6b460fcdd351 (patch)
treefc9b19aa65204455af9b1fcac347858981c1be9c /libre/faience-icon-theme/PKGBUILD
parent27d9389672acfcd3a0edec4ac13fe4dabbca05c5 (diff)
downloadabslibre-288a48d376f96b670f699dc321ec6b460fcdd351.tar.gz
abslibre-288a48d376f96b670f699dc321ec6b460fcdd351.tar.bz2
abslibre-288a48d376f96b670f699dc321ec6b460fcdd351.zip
faience-icon-theme: remove libre suffix and add complex pkgrel
Diffstat (limited to 'libre/faience-icon-theme/PKGBUILD')
-rw-r--r--libre/faience-icon-theme/PKGBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/libre/faience-icon-theme/PKGBUILD b/libre/faience-icon-theme/PKGBUILD
new file mode 100644
index 000000000..f56de653d
--- /dev/null
+++ b/libre/faience-icon-theme/PKGBUILD
@@ -0,0 +1,52 @@
+# $Id: PKGBUILD 114621 2014-07-02 09:40:38Z alucryd $
+# Maintainer (Arch): Maxime Gauduin <alucryd@gmail.com>
+# Contributor (Arch): Ner0 <darkelfdarkelf666@yahoo.co.uk>
+# Contributor (Arch): Sander Deryckere <sanderd17@gmail.com>
+# Maintainer: André Silva <emulatorman@parabola.nu>
+# Contributor: Jorge Araya Navarro <elcorreo@deshackra.com>
+# Contributor: Márcio Silva <coadde@parabola.nu>
+
+pkgname=faience-icon-theme
+pkgver=0.5.1
+pkgrel=3.parabola1
+pkgdesc='An icon theme based on Faenza, without nonfree distros and application icons (Parabola rebranded)'
+url='http://tiheum.deviantart.com/art/Faience-icon-theme-255099649'
+license=('GPL3')
+arch=('any')
+replaces=(${pkgname}-libre)
+conflicts=(${pkgname}-libre)
+depends=('faenza-icon-theme')
+source=("http://ppa.launchpad.net/tiheum/equinox/ubuntu/pool/main/f/${pkgname}/${pkgname}_${pkgver}.tar.gz"
+ 'start-here-parabola-symbolic.svg')
+sha256sums=('da4e6e921c465caeb8904d4fc6a183b173c8000c08abce625b5b6739f5a0867a'
+ 'ad3a47c9545358046b8ef1695cbc6effc913d7affbf27017744419d33e66aea6')
+
+prepare() {
+ cd ${pkgname}-${pkgver%.*}
+ rm -rv debian
+
+ # remove nonfree distros and application logos
+ for nonfree in archlinux debian fedora frugalware gentoo linux-mint mandriva opensuse redhat slackware ubuntu flash rpmdrake skype; do
+ find -name *$nonfree* -delete
+ done
+
+ # add the Parabola GNU/Linux-libre logo to the source code
+ cp -a "$srcdir/start-here-parabola-symbolic.svg" Faience/places/scalable
+
+ # set the Parabola GNU/Linux-libre start menu logo
+ cd Faience/places/scalable
+ ln -sf start-here{-parabola-symbolic,-symbolic}.svg
+}
+
+package() {
+ cd ${pkgname}-${pkgver%.*}
+
+ install -dm 755 "${pkgdir}"/usr/share/icons
+ cp -dr --no-preserve=ownership Faience* "${pkgdir}"/usr/share/icons/
+
+# Fix permissions
+ find "${pkgdir}" -type d -exec chmod 755 {} +
+ find "${pkgdir}" -type f -exec chmod 644 {} +
+}
+
+# vim: ts=2 sw=2 et: