summaryrefslogtreecommitdiff
path: root/libre/doublecmd-libre/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-05-07 04:20:07 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-05-07 04:20:07 -0300
commit91188d9c9957103b52a2a0acc70b23284e397b49 (patch)
treeb9299060e9715efe324eaec44a13b697709c3a0a /libre/doublecmd-libre/PKGBUILD
parent1a3ce27a07f876210a439d8cefb3bdca5b267da7 (diff)
downloadabslibre-91188d9c9957103b52a2a0acc70b23284e397b49.tar.gz
abslibre-91188d9c9957103b52a2a0acc70b23284e397b49.tar.bz2
abslibre-91188d9c9957103b52a2a0acc70b23284e397b49.zip
doublecmd-libre-0.5.9-1.2: remove nonfree libunrar, unace, unarj support and references, also nonfree unRAR utility files was removed from the source
Diffstat (limited to 'libre/doublecmd-libre/PKGBUILD')
-rw-r--r--libre/doublecmd-libre/PKGBUILD42
1 files changed, 36 insertions, 6 deletions
diff --git a/libre/doublecmd-libre/PKGBUILD b/libre/doublecmd-libre/PKGBUILD
index 1e14d5588..ad04bab90 100644
--- a/libre/doublecmd-libre/PKGBUILD
+++ b/libre/doublecmd-libre/PKGBUILD
@@ -8,7 +8,7 @@ pkgbase=doublecmd-libre
pkgname=('doublecmd-libre-gtk2' 'doublecmd-libre-qt')
pkgver=0.5.9
_helpver=0.5.5
-pkgrel=1.1
+pkgrel=1.2
url="http://doublecmd.sourceforge.net/"
arch=('i686' 'x86_64')
license=('GPL')
@@ -19,12 +19,39 @@ optdepends=(
'lua51: scripting'
'p7zip: support for 7zip archives'
)
-source=(
+mksource=(
"http://downloads.sourceforge.net/project/$_pkgbase/Double%20Commander%20Source/$_pkgbase-$pkgver-src.tar.gz"
+)
+source=(
+ "https://repo.parabolagnulinux.org/other/$pkgname/$pkgbase-$pkgver-src.tar.gz"
"http://downloads.sourceforge.net/project/$_pkgbase/Double%20Commander%20Source/$_pkgbase-help-$_helpver-src.tar.gz"
"http://www.herecura.be/files/lazarus-20140321-2.tar.gz"
+ 'libre.patch'
+ 'help-libre.patch'
)
+mksource() {
+ cd "$srcdir/$_pkgbase-$pkgver"
+
+ msg2 'remove nonfree unRAR utility files from the source'
+ rm -rv install/linux/deb/libunrar
+}
+
+prepare() {
+ cd "$srcdir/$_pkgbase-$pkgver"
+
+ msg2 'remove nonfree libunrar, unace, unarj support and references'
+ rm -rv plugins/wcx/unrar
+ rm -v install/linux/rpm/libunrar.spec
+ rm -v install/darwin/make-unrar.sh
+ patch -Np1 -i ../libre.patch
+
+ cd "$srcdir/$_pkgbase-help-$_helpver"
+
+ msg2 'remove nonfree libunrar, unace, unarj support and references on the help'
+ patch -Np1 -i ../help-libre.patch
+}
+
build() {
cp -a $_pkgbase-$pkgver $_pkgbase-gtk
cp -a $_pkgbase-$pkgver $_pkgbase-qt
@@ -48,7 +75,7 @@ build() {
}
package_doublecmd-libre-gtk2() {
- pkgdesc="twin-panel (commander-style) file manager (GTK), without nonfree libunrar recommendation"
+ pkgdesc="twin-panel (commander-style) file manager (GTK), without nonfree libunrar, unace and unarj support"
depends=('gtk2')
conflicts=('doublecmd-libre-qt' 'doublecmd-gtk2' 'doublecmd-gtk2-libre')
replaces=('doublecmd-gtk2' 'doublecmd-gtk2-libre')
@@ -62,7 +89,7 @@ package_doublecmd-libre-gtk2() {
}
package_doublecmd-libre-qt() {
- pkgdesc="twin-panel (commander-style) file manager (QT), without nonfree libunrar recommendation"
+ pkgdesc="twin-panel (commander-style) file manager (QT), without nonfree libunrar, unace and unarj support"
depends=('qt4pas')
conflicts=('doublecmd-libre-gtk2' 'doublecmd-qt' 'doublecmd-qt-libre')
replaces=('doublecmd-qt' 'doublecmd-qt-libre')
@@ -75,6 +102,9 @@ package_doublecmd-libre-qt() {
cp -a * "$pkgdir/usr/share/$_pkgbase/doc/"
}
-sha256sums=('d5b3c93b3029f4b0a45b7c9912d34f753445e031c93bc0268d4cb4c313d06ba4'
+mksha256sums=('d5b3c93b3029f4b0a45b7c9912d34f753445e031c93bc0268d4cb4c313d06ba4')
+sha256sums=('d72f0e52f99fadcd5ebcc7cf6184394c124da57dda6b6af05774a1f5e767254e'
'5c5d00187df811df0734bf751a581bce7e1bdd4cf4639b2a1101f1da8743daaf'
- '16560ad7403ffbee1800384768828e1fad924d03068c6248b68a78c393fc4e20')
+ '16560ad7403ffbee1800384768828e1fad924d03068c6248b68a78c393fc4e20'
+ '79853d83a2fa7cdb54ab79586c2c3d123de90f849dd52d1a712b1e4a1eeaefcd'
+ '3f0de0b4a35ec3c8a172864f3e6fd2ad11d3c32c3eee05d08b51d06002d05f7f')