summaryrefslogtreecommitdiff
path: root/libre/doublecmd-libre/PKGBUILD
diff options
context:
space:
mode:
authorcoadde [Márcio Alexandre Silva Delgado] <coadde@parabola.nu>2014-09-04 02:24:10 -0300
committercoadde [Márcio Alexandre Silva Delgado] <coadde@parabola.nu>2014-09-04 02:24:10 -0300
commit0873eff3fe57c9e108ef0cf5f5b700bbb449629a (patch)
treef6f991ca382bdc07245a935918050b4cf847398b /libre/doublecmd-libre/PKGBUILD
parent035f2fd609cd247ac0430f15cad3af94ce79f5f8 (diff)
downloadabslibre-0873eff3fe57c9e108ef0cf5f5b700bbb449629a.tar.gz
abslibre-0873eff3fe57c9e108ef0cf5f5b700bbb449629a.tar.bz2
abslibre-0873eff3fe57c9e108ef0cf5f5b700bbb449629a.zip
rename to doublecmd
Diffstat (limited to 'libre/doublecmd-libre/PKGBUILD')
-rw-r--r--libre/doublecmd-libre/PKGBUILD110
1 files changed, 0 insertions, 110 deletions
diff --git a/libre/doublecmd-libre/PKGBUILD b/libre/doublecmd-libre/PKGBUILD
deleted file mode 100644
index 806913117..000000000
--- a/libre/doublecmd-libre/PKGBUILD
+++ /dev/null
@@ -1,110 +0,0 @@
-# vim:set ft=sh:
-# $Id: PKGBUILD 111059 2014-05-12 18:14:06Z idevolder $
-# Maintainer (Arch): BlackIkeEagle <ike DOT devolder AT gmail DOT com>
-# Contributor (Arch): (sirocco AT ngs.ru)
-
-_pkgbase=doublecmd
-pkgbase=doublecmd-libre
-pkgname=('doublecmd-libre-gtk2' 'doublecmd-libre-qt')
-pkgver=0.5.10
-_helpver=0.5.5
-pkgrel=1
-url="http://doublecmd.sourceforge.net/"
-arch=('i686' 'x86_64' 'mips64el')
-license=('GPL')
-install="$_pkgbase.install"
-provides=("$_pkgbase")
-makedepends=('lazarus' 'qt4pas' 'gtk2')
-optdepends=(
- 'lua51: scripting'
- 'p7zip: support for 7zip archives'
-)
-mksource=(
- "http://downloads.sourceforge.net/project/$_pkgbase/Double%20Commander%20Source/$_pkgbase-$pkgver-src.tar.gz"
-)
-source=(
- "https://repo.parabolagnulinux.org/other/$pkgbase/$pkgbase-$pkgver-src.tar.gz"
- "http://downloads.sourceforge.net/project/$_pkgbase/Double%20Commander%20Source/$_pkgbase-help-$_helpver-src.tar.gz"
- "http://www.herecura.be/files/lazarus-20140321-2.tar.gz"
- 'libre.patch'
- 'help-libre.patch'
-)
-
-mksource() {
- cd "$srcdir/$_pkgbase-$pkgver"
-
- msg2 'remove nonfree unRAR utility files from the source'
- rm -rv install/linux/deb/libunrar
-}
-
-prepare() {
- cd "$srcdir/$_pkgbase-$pkgver"
-
- msg2 'remove nonfree libunrar, unace, unarj support and references'
- rm -rv plugins/wcx/unrar
- rm -v install/linux/rpm/libunrar.spec
- rm -v install/darwin/make-unrar.sh
- patch -Np1 -i ../libre.patch
-
- cd "$srcdir/$_pkgbase-help-$_helpver"
-
- msg2 'remove nonfree libunrar, unace, unarj support and references on the help'
- patch -Np1 -i ../help-libre.patch
-}
-
-build() {
- cp -a $_pkgbase-$pkgver $_pkgbase-gtk
- cp -a $_pkgbase-$pkgver $_pkgbase-qt
-
- msg2 'build gtk'
- gtkdir="$srcdir/$_pkgbase-gtk"
- cd "$gtkdir"
- bsdtar -zxf "$srcdir/lazarus-20140321-2.tar.gz"
- sed -e "s/\\(export\\ lazbuild=\\).*/\\1\"\$(which lazbuild) --primary-config-path=${gtkdir//\//\\\/}\/lazarus\/lazarus-$CARCH\"/" -i build.sh
- sed -e "s/%%SRCDIR%%/${gtkdir//\//\\\/}/g" -i lazarus/packagefiles.xml
- ./build.sh beta gtk2
-
- msg2 'build qt'
- qtdir="$srcdir/$_pkgbase-qt"
- cd "$qtdir"
- bsdtar -zxf "$srcdir/lazarus-20140321-2.tar.gz"
- sed -e "s/\\(export\\ lazbuild=\\).*/\\1\"\$(which lazbuild) --primary-config-path=${qtdir//\//\\\/}\/lazarus\/lazarus-$CARCH\"/" -i build.sh
- sed -e "s/%%SRCDIR%%/${qtdir//\//\\\/}/g" -i lazarus/packagefiles.xml
- ./build.sh beta qt
-
-}
-
-package_doublecmd-libre-gtk2() {
- pkgdesc="twin-panel (commander-style) file manager (GTK), without nonfree libunrar, unace and unarj support"
- depends=('gtk2')
- conflicts=('doublecmd-libre-qt' 'doublecmd-gtk2' 'doublecmd-gtk2-libre')
- replaces=('doublecmd-gtk2' 'doublecmd-gtk2-libre')
- provides=("doublecmd-gtk2=${pkgver}" 'doublecmd-gtk2-libre')
- cd "$srcdir/$_pkgbase-gtk"
- ./install/linux/install.sh --install-prefix="$pkgdir"
-
- # install doc
- cd "$srcdir/$_pkgbase-help-$_helpver"
- cp -a * "$pkgdir/usr/share/$_pkgbase/doc/"
-}
-
-package_doublecmd-libre-qt() {
- pkgdesc="twin-panel (commander-style) file manager (QT), without nonfree libunrar, unace and unarj support"
- depends=('qt4pas')
- conflicts=('doublecmd-libre-gtk2' 'doublecmd-qt' 'doublecmd-qt-libre')
- replaces=('doublecmd-qt' 'doublecmd-qt-libre')
- provides=("doublecmd-qt=${pkgver}" 'doublecmd-qt-libre')
- cd "$srcdir/$_pkgbase-qt"
- ./install/linux/install.sh --install-prefix="$pkgdir"
-
- # install doc
- cd "$srcdir/$_pkgbase-help-$_helpver"
- cp -a * "$pkgdir/usr/share/$_pkgbase/doc/"
-}
-
-mksha256sums=('cc54a2d973836f46f6f99fff1b8dd631bc96d8aa8524c3cd9cfc60b0c7a3dc12')
-sha256sums=('7a194a40930aaffc7772a2ad14f53af287bdc61cc967d4179223815da4a169a7'
- '5c5d00187df811df0734bf751a581bce7e1bdd4cf4639b2a1101f1da8743daaf'
- '16560ad7403ffbee1800384768828e1fad924d03068c6248b68a78c393fc4e20'
- '79853d83a2fa7cdb54ab79586c2c3d123de90f849dd52d1a712b1e4a1eeaefcd'
- '3f0de0b4a35ec3c8a172864f3e6fd2ad11d3c32c3eee05d08b51d06002d05f7f')