summaryrefslogtreecommitdiff
path: root/libre/debootstrap/PKGBUILD
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>2018-11-10 18:52:05 +0100
committerDenis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>2018-11-11 17:53:47 +0100
commit63ab5673653f53da1e54219fe0f16c4758072b31 (patch)
tree6346bdc86b7107de8daf942ed883fd2c8b6633f2 /libre/debootstrap/PKGBUILD
parent532939ba18a14942d7e4ebc5954c706b40f97f5a (diff)
downloadabslibre-63ab5673653f53da1e54219fe0f16c4758072b31.tar.gz
abslibre-63ab5673653f53da1e54219fe0f16c4758072b31.tar.bz2
abslibre-63ab5673653f53da1e54219fe0f16c4758072b31.zip
debootstrap: switch to the 1.0.110 version to repair Trisquel
Trisquel debootstrap was broken by the switch to the 1.0.109 version. This fixes that by switching to the 1.0.110 version and syncing the trisquel script with the upstream debootstrap's gutsy script. This commit was tested with: - Trisquel flidas: test OK - Trisquel belenos: test OK - Trisquel toutatis: test OK The following things were tested: - debootstrap return code (0 for success) - the presence of the usual folders (bin, boot, dev, etc) The tests were done the following way: (1) The package was built and installed (2) an empty rootfs directory was created (3) debootstrap was run in this directory with: sudo debootstrap "${version}" rootfs/ http://archive.trisquel.info/trisquel with version being the trisquel version(flidas, belenos, etc) (4) The exit code was checked and the directories listed inside the rootfs directory Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
Diffstat (limited to 'libre/debootstrap/PKGBUILD')
-rw-r--r--libre/debootstrap/PKGBUILD21
1 files changed, 15 insertions, 6 deletions
diff --git a/libre/debootstrap/PKGBUILD b/libre/debootstrap/PKGBUILD
index 24a65283b..02167ab2a 100644
--- a/libre/debootstrap/PKGBUILD
+++ b/libre/debootstrap/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: André Silva <emulatorman@hyperbola.info>
pkgname=debootstrap
-pkgver=1.0.109
+pkgver=1.0.110
pkgrel=1
pkgrel+=.par1
pkgdesc="Bootstrap a basic gNewSense and Trisquel system, without Debian support"
@@ -18,12 +18,13 @@ source=("$pkgname-$pkgver.tar.gz::https://github.com/felixonmars/debootstrap/arc
debootstrap.8
gnewsense
trisquel)
-optdepends=('gnupg: check release signatures')
-sha512sums=('8b2cf0ba3e0c672a2375ff323c18c18788e17a4bdf3e03d6b72f956a85b989d3998b89215bc7b99925decbba3c9a5dbeddfc72b9baf7c0571f11559ff8286272'
+optdepends=('gnupg: check release signatures'
+ 'trisquel-keyring: check Trisquel release signatures')
+sha512sums=('e687bd3ca43f41f2f2d196b1519e6a7cc3a3e63d9b2e50c808a7508ff90aece4499d61f613a872325df27e44b723e9157a27f85f0e0aa355e49017f84bbb1561'
'56e25f48027f99f7e720859a9e14fe769b1cbd6227c7a7e27e14c2fea88520109342d6e5b127dc34ce8cc40f46941a0c5157ad35cf8ef9b3e4323877a4b32d97'
'0b3507756b8f29d19146df3201143ccbd71cfd1f7ef865d184079180612b90c046cabab59fe42d246bfe476ae8fd5c43e81ee2fc3ee06bbc1fc3e75d9f1382ca'
'968ef005bf1f399b3400080b2ba65f1b32c067c49faadc1caa7ee524a85980f0a6625c7b06838e01bbd8b99a496492da77a38f0e17f0a81fc029ee611fe639b6'
- 'b192dcbd0d85923ddd97d1094bbcf36edb36a095bfe06e0971707651524f6712c7ab21f733ba6f24e5cbc2e977aec7c52645e41b78d04e45fca65971f89a47a7')
+ 'bf0310b9c4c7ad03bfcb0f47dff80e66fbb30f1d010a00137dcce84e52ff97c145bfa8079d9a05393e7e11a50c52656f2f555c5e53960643c8e2c7813acf4bfc')
prepare() {
cd debootstrap-$pkgver
@@ -42,8 +43,16 @@ prepare() {
# Add rebranded man
install -m644 ../debootstrap.8 .
- # Remove Debian scripts
- rm -v scripts/*
+ # Remove (non-FSDG compliant) distributions's scripts
+ for SCRIPT in scripts/* ; do
+ case $SCRIPT in
+ scripts/debian-common)
+ ;;
+ *)
+ rm -v $SCRIPT
+ ;;
+ esac
+ done
# Add gNewSense script
install -m644 $srcdir/gnewsense scripts