summaryrefslogtreecommitdiff
path: root/libre/debhelper/PKGBUILD
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2012-04-02 17:48:39 -0400
committerLuke Shumaker <LukeShu@sbcglobal.net>2012-04-02 17:48:39 -0400
commit158b35a711165b70a2b718b01cbc261ba50a5cf1 (patch)
tree55672c1404147bcfccfbebc79bb31019ef291d73 /libre/debhelper/PKGBUILD
parenta896e039514a8f7a529042b373eb227d7e2c9b29 (diff)
downloadabslibre-158b35a711165b70a2b718b01cbc261ba50a5cf1.tar.gz
abslibre-158b35a711165b70a2b718b01cbc261ba50a5cf1.tar.bz2
abslibre-158b35a711165b70a2b718b01cbc261ba50a5cf1.zip
add libre/{debhelper,dpkg} for the purpose of using debhelper to compile iceweasel
Diffstat (limited to 'libre/debhelper/PKGBUILD')
-rw-r--r--libre/debhelper/PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/libre/debhelper/PKGBUILD b/libre/debhelper/PKGBUILD
new file mode 100644
index 000000000..60ff8f267
--- /dev/null
+++ b/libre/debhelper/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer (AUR): Antoine Lubineau <antoine@lubignon.info>
+# Contributor (AUR): Andrei "Garoth" Thorp <garoth@gmail.com>
+# Contributor (Parabola): Luke Shumaker <lukeshu@sbcglobal.net>
+
+_debrepo=http://ftp.debian.org/debian/pool/main/ # Debian Sid
+debfile() { echo -n "$_debrepo"; echo -n "$@"|sed -r 's@(.).*@\1/&@'; }
+
+pkgname=debhelper
+pkgver=9.20120322
+pkgrel=1
+pkgdesc="A collection of programs that can be used in a debian/rules file to automate common tasks"
+arch=('any')
+url="http://packages.debian.org/${pkgname}"
+license='GPL3'
+depends=('binutils' 'dpkg' 'file' 'html2text' 'man-db' 'perl')
+makedepends=('po4a')
+source=(`debfile ${pkgname}`/${pkgname}_$pkgver.tar.gz)
+
+build() {
+ cd "$srcdir/$pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums=('9ea56782e6396a59ec49f45f9c4a603f')