summaryrefslogtreecommitdiff
path: root/libre/clementine-libre/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@lavabit.com>2013-05-13 03:27:54 -0300
committerAndré Fabian Silva Delgado <emulatorman@lavabit.com>2013-05-13 03:27:54 -0300
commit8d3dad48788d6c822a841306aecf71298823865b (patch)
treef05daca4cfbc3e532354245729d3a6010bc569db /libre/clementine-libre/PKGBUILD
parent0eff4f3d32968e49db17bba4554fc0db6c12490d (diff)
downloadabslibre-8d3dad48788d6c822a841306aecf71298823865b.tar.gz
abslibre-8d3dad48788d6c822a841306aecf71298823865b.tar.bz2
abslibre-8d3dad48788d6c822a841306aecf71298823865b.zip
clementine-libre: adding new changes reported from https://labs.parabola.nu/issues/328 and https://labs.parabola.nu/issues/329
Diffstat (limited to 'libre/clementine-libre/PKGBUILD')
-rw-r--r--libre/clementine-libre/PKGBUILD20
1 files changed, 15 insertions, 5 deletions
diff --git a/libre/clementine-libre/PKGBUILD b/libre/clementine-libre/PKGBUILD
index 0daf90aec..cb1978d4f 100644
--- a/libre/clementine-libre/PKGBUILD
+++ b/libre/clementine-libre/PKGBUILD
@@ -10,7 +10,7 @@ _pkgname=clementine
pkgname=clementine-libre
pkgver=1.1.1
pkgrel=8
-pkgdesc="A music player and library organizer, without spotify support"
+pkgdesc="A music player and library organizer, without nonfree artwork and spotify support"
url="http://www.clementine-player.org/"
license=('GPL')
arch=('i686' 'x86_64')
@@ -27,7 +27,8 @@ conflicts=('clementine')
provides=("clementine=$pkgver")
source=(http://clementine-player.googlecode.com/files/${_pkgname}-${pkgver}.tar.gz
'clementine-1.1.1-libimobiledevice-fix.patch'
- 'remove-and-disable-spotify.patch')
+ 'remove-nonfree-artwork-and-spotify.patch'
+ 'moognu.png')
install=clementine.install
build() {
@@ -35,18 +36,25 @@ build() {
patch -Np1 < "$srcdir"/clementine-1.1.1-libimobiledevice-fix.patch
- # Remove nonfree spotify references on files
- patch -Np1 -i ../remove-and-disable-spotify.patch
+ # Remove nonfree nonfree artwork and spotify references on files
+ patch -Np1 -i ../remove-nonfree-artwork-and-spotify.patch
# Remove nonfree spotifyblob folders
rm -rv ext/{clementine-spotifyblob,libclementine-spotifyblob}
# Remove nonfree spotify files
rm -v cmake/SpotifyVersion.cmake
+ rm -v data/spotify-core-logo-128x128.png
rm -v data/icons/svg/spotify.svg
rm -v data/schema/schema-30.sql
rm -v src/{globalsearch/spotifysearchprovider.{cpp,h},internet/spotify{blobdownloader.{cpp,h},server.{cpp,h},service.{cpp,h},settingspage.{cpp,h,ui}}}
+ ## Remove nonfree nyancat.png
+ rm -v data/nyancat.png
+
+ ## Put moognu.png to the source code
+ cp -v "{srcdir}/moognu.png" data
+
# Create a blank file due that is a dependency for clementine
touch data/schema/schema-30.sql
@@ -59,4 +67,6 @@ package() {
make DESTDIR="${pkgdir}" install
}
md5sums=('28e4afb822388bd337a761db8f86febf'
- '736df6cd828a3172701f63c8dc978cb9')
+ '736df6cd828a3172701f63c8dc978cb9'
+ '2ab57bff0ed8f7ba0d96d561ac54d1c2'
+ '59a8c0d7659898c457b95f877718cf1c')