summaryrefslogtreecommitdiff
path: root/libre/clementine-libre/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@lavabit.com>2012-10-26 04:24:02 -0200
committerAndré Fabian Silva Delgado <emulatorman@lavabit.com>2012-10-26 04:24:02 -0200
commit020be9d8aff29e757532348492c365e0a69b9137 (patch)
tree575a34213a1f45802eafb97bd824a0323a892856 /libre/clementine-libre/PKGBUILD
parent3e7c37fcbb6aef33580ec69c215dd186cf8af978 (diff)
downloadabslibre-020be9d8aff29e757532348492c365e0a69b9137.tar.gz
abslibre-020be9d8aff29e757532348492c365e0a69b9137.tar.bz2
abslibre-020be9d8aff29e757532348492c365e0a69b9137.zip
clementine-libre-1.1.0-2: updating version
Diffstat (limited to 'libre/clementine-libre/PKGBUILD')
-rwxr-xr-xlibre/clementine-libre/PKGBUILD47
1 files changed, 18 insertions, 29 deletions
diff --git a/libre/clementine-libre/PKGBUILD b/libre/clementine-libre/PKGBUILD
index 473fd3cce..c0a063e95 100755
--- a/libre/clementine-libre/PKGBUILD
+++ b/libre/clementine-libre/PKGBUILD
@@ -2,13 +2,13 @@
#Maintainer: Stéphane Gaudreault <stephane@archlinux.org>
#Contributor: BlackEagle <ike.devolder@gmail.com>
#Contributor: Dany Martineau <dany.luc.martineau@gmail.com>
-#Maintainer (Parabola): Kete <kete@ninthfloor.org>
-#Contributor (Parabola): André Silva <emulatorman@lavabit.com>
+#Maintainer (Parabola): André Silva <emulatorman@lavabit.com>
+#Contributor (Parabola): Kete <kete@ninthfloor.org>
_pkgname=clementine
pkgname=clementine-libre
-pkgver=1.0.1
-pkgrel=7
+pkgver=1.1.0
+pkgrel=2
pkgdesc="A music player and library organizer, without spotify support"
url="http://www.clementine-player.org/"
license=('GPL')
@@ -16,7 +16,7 @@ arch=('i686' 'x86_64')
depends=('gstreamer0.10-base' 'taglib' 'glew' 'liblastfm' 'libgpod'
'libmtp' 'libplist' 'hicolor-icon-theme' 'qt' 'libimobiledevice'
'qjson' 'libcdio' 'protobuf' 'qca' 'qca-ossl' 'gvfs')
-makedepends=('cmake' 'boost')
+makedepends=('cmake' 'boost' 'mesa')
optdepends=('gstreamer0.10-base-plugins: for more open formats'
'gstreamer0.10-good-plugins: for use with "Good" plugin libraries'
'gstreamer0.10-bad-libre-plugins: for use with "Bad" plugin libraries'
@@ -25,37 +25,26 @@ replaces=('clementine')
conflicts=('clementine')
provides=("clementine=$pkgver")
source=(http://clementine-player.googlecode.com/files/${_pkgname}-${pkgver}.tar.gz
- clementine-fix-albumcoverfetch-crash.patch
- clementine-fresh-start.patch
- imobiledevice.patch
- remove-and-disable-spotify.patch
- remove-nonfree-references-on-translations.patch)
-sha1sums=('e05320da689e2fad744fd3e68518bc4103ecf0fd'
- 'fddd2e784181ce1dcc7809e7122cbade0af7b01f'
- 'd8abab4b8fb2d5284a2f43107505325e62d4af5f'
- 'a04cec00e38651de78bfaa6b6d73532c3786de11'
- '2fef46eaffa7b5cd61afbf19b1dc909d11972a34'
- '745bc4fd639d7ef3230592c6275fb43b8956f3d5')
+ remove-and-disable-spotify.patch)
+sha1sums=('af446aba5ca89edd1541871969b3b6738ffbd05f'
+ '3980a00c02e406226f0d08ae9b7e581702c89838')
install=clementine.install
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- # https://bugs.gentoo.org/401713?id=401713
- patch -Np1 -i ../clementine-fresh-start.patch
-
- # http://code.google.com/p/clementine-player/issues/detail?id=2752
- patch -Np1 -i ../clementine-fix-albumcoverfetch-crash.patch
-
- # Use libimobiledevice new "udid" field instead of "uuid".
- patch -Np1 -i ../imobiledevice.patch
-
- # https://labs.parabola.nu/issues/99
+ # Remove nonfree spotify references on files
patch -Np1 -i ../remove-and-disable-spotify.patch
- patch -Np1 -i ../remove-nonfree-references-on-translations.patch
- # Remove nonfree spotifyblob folder
- rm -Rf "./spotifyblob"
+ # Remove nonfree spotifyblob folders
+ rm -rv ext/{clementine-spotifyblob,libclementine-spotifyblob}
+
+ # Remove nonfree spotify files
+ rm -v cmake/SpotifyVersion.cmake
+ rm -v data/icons/svg/spotify.svg
+ rm -v data/schema/schema-30.sql
+ rm -v src/{globalsearch/spotifysearchprovider.{cpp,h},internet/spotify{blobdownloader.{cpp,h},server.{cpp,h},service.{cpp,h},settingspage.{cpp,h,ui}}}
+
cmake . -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
make