summaryrefslogtreecommitdiff
path: root/libre/calibre/PKGBUILD
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2019-10-11 04:15:56 -0400
committerbill-auger <mr.j.spam.me@gmail.com>2019-10-11 06:39:58 -0400
commitd3e05e0af22e380df9069dc24b2dfde92de5f1b4 (patch)
tree5dbdc1982f51cbf5dd224f86639d7602573d02ce /libre/calibre/PKGBUILD
parent8183d329491a525f976afee5bc6db661a40ab3cc (diff)
downloadabslibre-d3e05e0af22e380df9069dc24b2dfde92de5f1b4.tar.gz
abslibre-d3e05e0af22e380df9069dc24b2dfde92de5f1b4.tar.bz2
abslibre-d3e05e0af22e380df9069dc24b2dfde92de5f1b4.zip
[calibre]: upgrade to v3.48.0
Diffstat (limited to 'libre/calibre/PKGBUILD')
-rw-r--r--libre/calibre/PKGBUILD26
1 files changed, 16 insertions, 10 deletions
diff --git a/libre/calibre/PKGBUILD b/libre/calibre/PKGBUILD
index 4e6ce9ad1..0417eb590 100644
--- a/libre/calibre/PKGBUILD
+++ b/libre/calibre/PKGBUILD
@@ -13,13 +13,14 @@
# parabola changes and rationale:
# - removed decrompession engine for rar archives
+# - frozen at v3.48.0 - v4.x and above replaced webkit with webengine
pkgname=calibre
-pkgver=3.46.0
+pkgver=3.48.0
pkgrel=1
-pkgrel+=.par1
+pkgrel+=.parabola1
pkgdesc="Ebook management application"
-pkgdesc+=", without nonfree decompression engine for RAR archives"
+pkgdesc+=", without nonfree RAR support, without webengine"
arch=('x86_64')
arch+=('i686' 'armv7h')
url="https://calibre-ebook.com/"
@@ -27,7 +28,7 @@ license=('GPL3')
_py_deps=('apsw' 'beautifulsoup4' 'cssselect' 'css-parser' 'dateutil' 'dbus' 'dnspython' 'dukpy'
'feedparser' 'html2text' 'html5-parser' 'lxml' 'markdown' 'mechanize' 'msgpack'
'netifaces' 'pillow' 'psutil' 'pygments' 'pyqt5' 'regex')
-depends=('chmlib' 'icu' 'jxrlib' 'libmtp' 'libusbx' 'libwmf' 'mathjax' 'mtdev' 'optipng'
+depends=('chmlib' 'hunspell' 'icu' 'jxrlib' 'libmtp' 'libusbx' 'libwmf' 'mathjax2' 'mtdev' 'optipng'
'podofo' "${_py_deps[@]/#/python2-}" 'qt5-svg' 'qt5-webkit' 'udisks2')
makedepends=('qt5-x11extras' 'rapydscript-ng' 'sip' 'xdg-utils')
checkdepends=('xorg-server-xvfb')
@@ -35,13 +36,16 @@ optdepends=('ipython2: to use calibre-debug'
'poppler: required for converting pdf to html')
source=("https://download.calibre-ebook.com/${pkgver}/calibre-${pkgver}.tar.xz"
"https://calibre-ebook.com/signatures/${pkgname}-${pkgver}.tar.xz.sig"
- 'libre.patch')
-sha256sums=('e947b9854f9db344ee07e5495feaad759c96936d89a128d3a3587c3503d09ab6'
+ 'libre.patch'
+ "https://github.com/kovidgoyal/calibre/commit/420e9e121b67db197e0c5d0bf23b92c174f2678f.patch")
+sha256sums=('024528f0f913c78e121fb34beb3dae8dba3686f2334422c6450808796042950c'
'SKIP'
- '1574e2094ce7f3e37116215ae117ed4a10426592535b261f66eacc1508566ad2')
-b2sums=('5590ba422d0323ea7c0cea67d88d448f00f5a470e7a8fdf9851b488c0856c88175bd107715a856706e95b2e1a45604713d061f4a7a3603ecaa01dfc018c1ed58'
+ '00c352f4a5b49da43f38e495e3a2d82144f753a3d797cec8b5870b872137a70b'
+ 'ff9be7c1773c18ccf4acaff5598ad29cf1477a1d33ddde85184d97f9a44ace1a')
+b2sums=('9a7fae20487ae93120cfdc06a312a42d54d68935fdd2bc18dc41be5f8d359c79eae24e0409ba8e7f4df85e2f073f80ce6bab56cba0638cead6693600fa93cb41'
'SKIP'
- '45a57037ad9f9b57c73e5eed8a5faf57e2be2bfdc6f4c2ff753cc536d5f8f8431d6cc9a8d64781caab47571d45fdb4476f1fecf0e759d388ca526ad36803c19b')
+ 'SKIP'
+ '29a3597676fd8a26d286363ba5002d2c439faba6c8cd3d6c98fd10f8aa3cd41021dbda501f445ed94759dc17561c945488822ba4f9e17334481d3261a973787c')
validpgpkeys=('3CE1780F78DD88DF45194FD706BC317B515ACE7C') # Kovid Goyal (New longer key) <kovid@kovidgoyal.net>
prepare(){
@@ -64,6 +68,8 @@ prepare(){
# needed for frozen builds + beautifulsoup4
# see https://github.com/kovidgoyal/calibre/commit/b177f0a1096b4fdabd8772dd9edc66662a69e683#commitcomment-33169700
rm -r src/backports
+ # de-vendor hunspell (back-ported from 4.x)
+ patch -p1 -i ../420e9e121b67db197e0c5d0bf23b92c174f2678f.patch
cd resources
@@ -82,7 +88,7 @@ build() {
LANG='en_US.UTF-8' python2 setup.py build
LANG='en_US.UTF-8' python2 setup.py gui
- LANG='en_US.UTF-8' python2 setup.py mathjax --path-to-mathjax /usr/share/mathjax --system-mathjax
+ LANG='en_US.UTF-8' python2 setup.py mathjax --path-to-mathjax /usr/share/mathjax2 --system-mathjax
LANG='en_US.UTF-8' python2 setup.py rapydscript
}