summaryrefslogtreecommitdiff
path: root/libre/bbswitch-parabola/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-08-27 06:05:47 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-08-27 06:05:47 -0300
commitd73f07b0acf8bae623e1e112a7cb3744a84a92ee (patch)
tree87a2b353ea5229bbe309ea9db9d43bf24e2a6fd8 /libre/bbswitch-parabola/PKGBUILD
parentc001329b017288676a28aa6078bf16ad42e318e9 (diff)
parent0ff008e3c9dcc5ef088f481dfff3dcd121575598 (diff)
downloadabslibre-d73f07b0acf8bae623e1e112a7cb3744a84a92ee.tar.gz
abslibre-d73f07b0acf8bae623e1e112a7cb3744a84a92ee.tar.bz2
abslibre-d73f07b0acf8bae623e1e112a7cb3744a84a92ee.zip
Merge branch 'master' of ssh://lukeshu.com:1863/srv/git/mirror/parabola/abslibre
Diffstat (limited to 'libre/bbswitch-parabola/PKGBUILD')
-rw-r--r--libre/bbswitch-parabola/PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/libre/bbswitch-parabola/PKGBUILD b/libre/bbswitch-parabola/PKGBUILD
index 209f58cec..9a664f09c 100644
--- a/libre/bbswitch-parabola/PKGBUILD
+++ b/libre/bbswitch-parabola/PKGBUILD
@@ -10,13 +10,13 @@ _basekernel=3.16
_kernelname=
_pkgname=bbswitch
-pkgname=${_pkgname}-parabola${_kernelname}
+pkgname=${_pkgname}${_kernelname}-parabola
pkgver=0.8
+pkgrel=15.2
_extramodules=extramodules-${_basekernel}${_kernelname}
-pkgrel=15.1
pkgdesc="Kernel module allowing to switch dedicated graphics card on Optimus laptops (built for the linux-libre${_kernelname} kernel package)"
arch=('i686' 'x86_64' 'mips64el')
-url="http://github.com/Bumblebee-Project/bbswitch"
+url="http://github.com/Bumblebee-Project/${_pkgname}"
license=('GPL')
# Generic (you shouldn't have to modify any of these variables)
@@ -46,9 +46,9 @@ package() {
# Set the correct extramodules directory for install
cp -f "${startdir}/${install}" "${startdir}/${install}.pkg"
true && install=${install}.pkg
- sed -i "s/^_EXTRAMODULES=$/_EXTRAMODULES="${_extramodules}"/" "${startdir}/${install}"
+ sed -i "s/^_EXTRAMODULES=.*/_EXTRAMODULES="${_extramodules}"/" "${startdir}/${install}"
# Actually install
- install -Dm644 bbswitch.ko "${pkgdir}"/usr/lib/modules/${_extramodules}/bbswitch.ko
- gzip "${pkgdir}/usr/lib/modules/${_extramodules}/bbswitch.ko"
+ install -Dm644 ${_pkgname}.ko "${pkgdir}"/usr/lib/modules/${_extramodules}/${_pkgname}.ko
+ gzip "${pkgdir}/usr/lib/modules/${_extramodules}/${_pkgname}.ko"
}