summaryrefslogtreecommitdiff
path: root/libre/base/PKGBUILD
diff options
context:
space:
mode:
authorDavid P <megver83@parabola.nu>2019-11-03 22:27:17 -0300
committerDavid P <megver83@parabola.nu>2019-11-03 22:27:17 -0300
commitde736afaecf00e766f3df3e28f8e8a2dee0a3406 (patch)
tree6d62a6f0a2df642db8ec7fcc9a50483713f53eff /libre/base/PKGBUILD
parent14f6ce90ee9ce334eafc00f064f3206d74c9e4b4 (diff)
downloadabslibre-de736afaecf00e766f3df3e28f8e8a2dee0a3406.tar.gz
abslibre-de736afaecf00e766f3df3e28f8e8a2dee0a3406.tar.bz2
abslibre-de736afaecf00e766f3df3e28f8e8a2dee0a3406.zip
move libre-testing/base -> libre/base
Signed-off-by: David P <megver83@parabola.nu>
Diffstat (limited to 'libre/base/PKGBUILD')
-rw-r--r--libre/base/PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/libre/base/PKGBUILD b/libre/base/PKGBUILD
new file mode 100644
index 000000000..3169bddd0
--- /dev/null
+++ b/libre/base/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer (Arch): Arch Linux Team
+# Contributor (Arch): Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor (Arch): Eli Schwartz <eschwartz@archlinux.org>
+# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
+
+pkgname=base
+pkgver=2
+pkgrel=1
+pkgrel+=.par2
+pkgdesc='Minimal package set to define a basic Parabola GNU/Linux-libre installation'
+url='https://www.parabola.nu'
+arch=('any')
+license=('GPL')
+depends=(
+ # very very base
+ 'filesystem' 'gcc-libs' 'glibc' 'bash'
+
+ # POSIX tools
+ 'coreutils' 'file' 'findutils' 'gawk' 'grep' 'procps-ng' 'sed' 'tar'
+
+ # standard linux toolset
+ 'gettext' 'pciutils' 'psmisc' 'shadow' 'util-linux' 'bzip2' 'gzip' 'xz'
+
+ # distro defined requirements
+ 'licenses' 'pacman' 'systemd-libudev' 'systemd-sysvcompat' 'systemd-udev'
+
+ # networking, ping, etc
+ 'iputils' 'iproute2'
+
+ # parabola
+ 'your-freedom'
+)
+optdepends=('linux-libre: bare metal support')
+
+# vim: ts=2 sw=2 et:
+