summaryrefslogtreecommitdiff
path: root/libre/avidemux-libre/PKGBUILD.WIP
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@lavabit.com>2013-08-01 06:04:56 -0300
committerAndré Fabian Silva Delgado <emulatorman@lavabit.com>2013-08-01 06:04:56 -0300
commit67ba0c1490ce7c6e126af7ff45e1efefe56bdce0 (patch)
treef962d3d7ea7a2efce78c8537d51ec81f074b41e1 /libre/avidemux-libre/PKGBUILD.WIP
parent942d1c9c10d16bd4e277bda711a09da5099b45f9 (diff)
downloadabslibre-67ba0c1490ce7c6e126af7ff45e1efefe56bdce0.tar.gz
abslibre-67ba0c1490ce7c6e126af7ff45e1efefe56bdce0.tar.bz2
abslibre-67ba0c1490ce7c6e126af7ff45e1efefe56bdce0.zip
avidemux-libre-2.5.6-7: Rebuild against ffmpeg 2.0 and x264 20130702, Add qt4 build fix
Diffstat (limited to 'libre/avidemux-libre/PKGBUILD.WIP')
-rw-r--r--libre/avidemux-libre/PKGBUILD.WIP71
1 files changed, 41 insertions, 30 deletions
diff --git a/libre/avidemux-libre/PKGBUILD.WIP b/libre/avidemux-libre/PKGBUILD.WIP
index c96084eb8..65499e1ef 100644
--- a/libre/avidemux-libre/PKGBUILD.WIP
+++ b/libre/avidemux-libre/PKGBUILD.WIP
@@ -1,36 +1,42 @@
# $Id: PKGBUILD 160693 2012-06-03 22:00:17Z eric $
# Maintainer: Eric Bélanger <eric@archlinux.org>
+# Maintainer (Parabola): André Silva <emulatorman@lavabit.com>
-pkgbase=avidemux
-pkgname=('avidemux-cli' 'avidemux-gtk' 'avidemux-qt')
-pkgver=2.6.1
+_pkgbase=avidemux
+pkgbase=avidemux-libre
+pkgname=('avidemux-libre-cli' 'avidemux-libre-gtk' 'avidemux-libre-qt')
+pkgver=2.6.4
pkgrel=1
arch=('i686' 'x86_64')
-license=('GPL')
+license=('GPL2')
url="http://fixounet.free.fr/avidemux/"
-makedepends=('cmake' 'libxslt' 'gtk3' 'qt' 'jack' 'libvorbis' 'sdl' 'libxv' \
- 'alsa-lib' 'lame' 'xvidcore' 'faad2' 'faac' 'x264' 'libsamplerate' \
+makedepends=('cmake' 'libxslt' 'gtk3' 'qt4' 'jack' 'libvorbis' 'sdl' 'libxv' \
+ 'alsa-lib' 'lame' 'xvidcore' 'faad2' 'x264' 'libsamplerate' \
'opencore-amr' 'yasm' 'mesa' 'libvpx' 'libpulse' 'libva' \
'libvdpau' 'libdca' 'fribidi' 'glu')
options=('!makeflags' '!emptydirs')
source=(http://downloads.sourceforge.net/avidemux/avidemux_${pkgver}.tar.gz)
-sha1sums=('a34ffc6409d96c3df30394fbd221e6693ec081ec')
-#source=(http://www.avidemux.org/nightly/source/snapshot_8273.tgz)
-#sha1sums=('cf5256ce189a51898a2e1071ffd46cd993f453f2')
+sha1sums=('7ed55fd5cfb6cfa73ebb9058af72fa2e3c9717c3')
+#source=(http://www.avidemux.org/nightly/snapshot/source_r8810.tar.gz)
+#sha1sums=('8c27d54e2b0655a8b8a3adfde1c0308ffedfec0c')
-build() {
-#mv snapshot_8273 ${pkgbase}_${pkgver}
-
- cd "${srcdir}/${pkgbase}_${pkgver}"
+prepare() {
+# mv 2.6_snapshot ${_pkgbase}_${pkgver}
+ cd ${_pkgbase}_${pkgver}
sed -i 's|avidemux2|avidemux3|' avidemux2.desktop
+ sed -i 's|../avidemux/qt4|../avidemux/qt4 -DLRELEASE_EXECUTABLE=/usr/bin/lrelease-qt4|' bootStrap.bash
+ sed -i 's|#include "ADM_files.h"|#include "ADM_files.h"\n#include "ADM_toolkitGtk.h"|' avidemux/gtk/ADM_userInterfaces/ui_support.cpp
+}
+
+build() {
+ cd ${_pkgbase}_${pkgver}
bash bootStrap.bash --with-core --with-cli --with-gtk --with-qt4 --with-plugins
}
-package_avidemux-cli() {
- pkgdesc="A graphical tool to edit video (filter/re-encode/split)"
+package_avidemux-libre-cli() {
+ pkgdesc="A graphical tool to edit video (filter/re-encode/split), without nonfree faac support"
depends=('libxml2' 'sdl' 'fontconfig' 'libvpx' 'libva')
optdepends=('lame: for the corresponding audio encoder plugin'
- 'faac: for the corresponding audio encoder plugin'
'faad2: for the corresponding audio decoder plugin'
'opencore-amr: for the corresponding audio decoder plugin'
'jack: for the corresponding audio device plugin'
@@ -38,11 +44,14 @@ package_avidemux-cli() {
'sdl: for the corresponding audio device plugin'
'x264: for the corresponding video encoder plugin'
'xvidcore: for the corresponding video encoder plugin'
- 'qt: for the QtScript scripting support'
+ 'qt4: for the QtScript scripting support'
'libdca: for the corresponding audio decoder plugin'
'fribidi: for the corresponding video filter plugin')
+ provides=('avidemux' 'avidemux-cli')
+ conflicts=('avidemux' 'avidemux-cli')
+ replaces=('avidemux' "avidemux-cli=$pkgver")
- cd "${srcdir}/${pkgbase}_${pkgver}"
+ cd ${_pkgbase}_${pkgver}
(cd buildCli; make DESTDIR="${pkgdir}" install)
(cd buildCore; make DESTDIR="${pkgdir}" install)
(cd buildPluginsCLI; make DESTDIR="${pkgdir}" install)
@@ -52,32 +61,34 @@ package_avidemux-cli() {
install -D -m644 man/avidemux.1 "${pkgdir}/usr/share/man/man1/avidemux.1"
}
-package_avidemux-gtk() {
- pkgdesc="A graphical tool to edit video (filter/re-encode/split) - GTK GUI"
- depends=("avidemux-cli=${pkgver}" 'gtk3' 'libxv' 'desktop-file-utils')
+package_avidemux-libre-gtk() {
+ pkgdesc="A graphical tool to edit video (filter/re-encode/split) - GTK GUI, without nonfree faac support"
+ depends=("avidemux-libre-cli=${pkgver}" 'gtk3' 'libxv' 'desktop-file-utils')
+ replaces=('avidemux-gtk')
+ conflicts=('avidemux-gtk')
+ provides=("avidemux-gtk=$pkgver")
install=avidemux.install
- cd "${srcdir}/${pkgbase}_${pkgver}"
+ cd ${_pkgbase}_${pkgver}
(cd buildGtk; make DESTDIR="${pkgdir}" install)
(cd buildPluginsGtk; make DESTDIR="${pkgdir}" install)
-
install -D -m644 avidemux2.desktop "${pkgdir}/usr/share/applications/avidemux-gtk.desktop"
- rm "${pkgdir}"/usr/lib/ADM_plugins6/pluginSettings/x264/1/{PSP.json,iPhone.json}
rm "${pkgdir}/usr/lib/ADM_plugins6/videoEncoders/libADM_ve_x264_other.so"
}
-package_avidemux-qt() {
- pkgdesc="A graphical tool to edit video (filter/re-encode/split) - QT GUI"
- depends=("avidemux-cli=${pkgver}" 'qt' 'x264' 'glu')
+package_avidemux-libre-qt() {
+ pkgdesc="A graphical tool to edit video (filter/re-encode/split) - QT GUI, without nonfree faac support"
+ depends=("avidemux-libre-cli=${pkgver}" 'qt4' 'x264' 'glu')
+ replaces=('avidemux-qt')
+ conflicts=('avidemux-qt')
+ provides=("avidemux-qt=$pkgver")
install=avidemux.install
- cd "${srcdir}/${pkgbase}_${pkgver}"
+ cd ${_pkgbase}_${pkgver}
(cd buildQt4; make DESTDIR="${pkgdir}" install)
(cd buildPluginsQt4; make DESTDIR="${pkgdir}" install)
install -D -m644 avidemux2.desktop "${pkgdir}/usr/share/applications/avidemux-qt.desktop"
sed -i 's|gtk|qt4|' "${pkgdir}/usr/share/applications/avidemux-qt.desktop"
-
- rm "${pkgdir}"/usr/lib/ADM_plugins6/pluginSettings/x264/1/{PSP.json,iPhone.json}
}