summaryrefslogtreecommitdiff
path: root/libre/atril/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2015-06-09 23:45:08 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2015-06-09 23:45:08 -0300
commit47404d5ed14719d8b0be17ea01aa72a2597e58fe (patch)
tree0ee803988e12b0fd9fa5251924d3e9545b1d5f3f /libre/atril/PKGBUILD
parent605f238e8be2d35c029b2525dc0c2132fc6039ef (diff)
downloadabslibre-47404d5ed14719d8b0be17ea01aa72a2597e58fe.tar.gz
abslibre-47404d5ed14719d8b0be17ea01aa72a2597e58fe.tar.bz2
abslibre-47404d5ed14719d8b0be17ea01aa72a2597e58fe.zip
atril-1.10.0-1.parabola1: updating version
Diffstat (limited to 'libre/atril/PKGBUILD')
-rw-r--r--libre/atril/PKGBUILD45
1 files changed, 18 insertions, 27 deletions
diff --git a/libre/atril/PKGBUILD b/libre/atril/PKGBUILD
index 1864baa18..a0a188c9a 100644
--- a/libre/atril/PKGBUILD
+++ b/libre/atril/PKGBUILD
@@ -1,50 +1,41 @@
-# $Id: PKGBUILD 120642 2014-10-14 14:16:49Z flexiondotorg $
# Maintainer (Arch): Martin Wimpress <code@flexion.org>
# Maintainer: André Silva <emulatorman@parabola.nu>
-pkgname=atril
-pkgver=1.8.1
-pkgrel=2.parabola1
-pkgdesc="Simply a document viewer, with libarchive support"
+_ver=1.10
+_pkgbase=atril
+pkgname=(${_pkgbase})
+pkgver=${_ver}.0
+pkgrel=1.parabola1
+pkgdesc="MATE document viewer (GTK2 version), with libarchive support for compressed comic books"
url="http://mate-desktop.org"
arch=('i686' 'x86_64' 'mips64el')
license=('GPL')
depends=('dconf' 'dbus' 'desktop-file-utils' 'gtk2' 'libsecret' 'libsm' 'libspectre'
- 'mate-desktop' 'mate-icon-theme' 'poppler-glib' 'zlib')
-makedepends=('caja' 'djvulibre' 'gobject-introspection' 'libgxps' 'mate-common'
- 'perl-xml-parser' 'texlive-bin' 'yelp-tools')
+ 'mate-desktop>=1.10' 'mate-icon-theme' 'poppler-glib' 'webkitgtk2' 'zlib' 'libarchive')
+makedepends=('caja>=1.10' 'djvulibre' 'gobject-introspection' 'libgxps'
+ 'mate-common' 'texlive-bin' 'yelp-tools')
optdepends=('caja: Document Properties extension'
'djvulibre: DjVu support'
'libgxps: XPS support'
- 'p7zip: cbz and cb7 compressed comic books'
'texlive-bin: DVI support'
- 'libarchive: cbr compressed comic books'
'yelp: for reading MATE help documents')
-replaces=('mate-document-viewer' "$pkgname-libre")
-provides=('mate-document-viewer')
-conflicts=('mate-document-viewer' "$pkgname-libre")
groups=('mate-extra')
-source=("http://pub.mate-desktop.org/releases/1.8/${pkgname}-${pkgver}.tar.xz"
- 'libarchive.patch')
-sha1sums=('2051be961a84d118ad0a278ec22bf48ca5d3fc35'
- 'e88168d61b18ce8e340ef3db9c6df6bb66c65d14')
-install=${pkgname}.install
-
-prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- patch -Np1 -i ../libarchive.patch
- NOCONFIGURE=1 ./autogen.sh
-}
+conflicts=("${_pkgbase}-gtk3" "${_pkgbase}-libre")
+replaces=("${_pkgbase}-libre")
+source=("http://pub.mate-desktop.org/releases/${_ver}/${_pkgbase}-${pkgver}.tar.xz")
+sha1sums=('7abd5b9310d88cb5da05248f1c55bb9ac069ac28')
+install=${_pkgbase}.install
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${_pkgbase}-${pkgver}"
./configure \
--prefix=/usr \
- --libexecdir=/usr/lib/${pkgname} \
+ --libexecdir=/usr/lib/${_pkgbase} \
--with-gtk=2.0 \
--enable-gtk-doc \
--enable-djvu \
--enable-dvi \
+ --enable-epub \
--enable-t1lib \
--enable-pixbuf \
--enable-comics \
@@ -55,6 +46,6 @@ build() {
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${_pkgbase}-${pkgver}"
make DESTDIR="${pkgdir}" install
}