summaryrefslogtreecommitdiff
path: root/libre-testing/uboot4extlinux-nitrogen6q/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2016-03-02 01:59:53 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2016-03-02 01:59:53 -0300
commit7545468778b501c3a5a805dc33bc8ae20019020e (patch)
treeeb54c7685473a31fa05d52c2defd095297af12b6 /libre-testing/uboot4extlinux-nitrogen6q/PKGBUILD
parentfc636b58da09547a89bd8955eef7b915efb9ed0f (diff)
downloadabslibre-7545468778b501c3a5a805dc33bc8ae20019020e.tar.gz
abslibre-7545468778b501c3a5a805dc33bc8ae20019020e.tar.bz2
abslibre-7545468778b501c3a5a805dc33bc8ae20019020e.zip
uboot4extlinux-nitrogen6q: add new package to [libre-testing]
Diffstat (limited to 'libre-testing/uboot4extlinux-nitrogen6q/PKGBUILD')
-rw-r--r--libre-testing/uboot4extlinux-nitrogen6q/PKGBUILD61
1 files changed, 61 insertions, 0 deletions
diff --git a/libre-testing/uboot4extlinux-nitrogen6q/PKGBUILD b/libre-testing/uboot4extlinux-nitrogen6q/PKGBUILD
new file mode 100644
index 000000000..83a69c4ad
--- /dev/null
+++ b/libre-testing/uboot4extlinux-nitrogen6q/PKGBUILD
@@ -0,0 +1,61 @@
+# U-Boot: Boundary Devices Nitrogen6X/Sabre Lite
+# Maintainer: André Silva <emulatorman@parabola.nu>
+
+buildarch=4
+
+pkgname=uboot4extlinux-nitrogen6q
+pkgver=2014.07
+pkgrel=1
+arch=('armv7h')
+pkgdesc="U-Boot with Extlinux support for Nitrogen6X/Sabre Lite"
+url="https://github.com/boundarydevices/u-boot-imx6/tree/production"
+license=('GPL')
+makedepends=('bc')
+conflicts=('uboot-nitrogen6q' 'uboot4grub-nitrogen6q')
+backup=(boot/extlinux/extlinux.conf)
+install=${pkgname}.install
+_commit=bb9dde563768731423fd6c560e95e1793a90710a
+source=("https://github.com/boundarydevices/u-boot-imx6/archive/${_commit}.tar.gz"
+ '0001-parabola-arm-modifications.patch'
+ '0002-kernel-add-support-for-gcc-5.patch'
+ '0003-ARM-asm-io.h-use-static-inline.patch'
+ '0004-common-main.c-make-show_boot_progress-__weak.patch'
+ '0005-common-board-use-__weak.patch'
+ '0006-common-board_f-cosmetic-use-__weak-for-leds.patch')
+md5sums=('b12f5f383c57de06f16625b3465e74d9'
+ '0cd5580fefd5abb6e09d8e9a964b932c'
+ '721a46867e189d8dedc6b6f86a536a34'
+ 'f6b687eca2d2d01f741cbda90dbacb41'
+ '8087672256020417438b12ec4946e1cf'
+ 'a536d28bf45add6dbf9f84277f943de8'
+ '2823d0e0c3c826632f6ae934f2b746d9')
+
+prepare() {
+ cd u-boot-imx6-${_commit}
+
+ patch -Np1 -i ../0001-parabola-arm-modifications.patch
+ patch -Np1 -i ../0002-kernel-add-support-for-gcc-5.patch
+ patch -Np1 -i ../0003-ARM-asm-io.h-use-static-inline.patch
+ patch -Np1 -i ../0004-common-main.c-make-show_boot_progress-__weak.patch
+ patch -Np1 -i ../0005-common-board-use-__weak.patch
+ patch -Np1 -i ../0006-common-board_f-cosmetic-use-__weak-for-leds.patch
+}
+
+build() {
+ cd u-boot-imx6-${_commit}
+
+ unset CFLAGS
+ unset CXXFLAGS
+
+ make distclean
+ make nitrogen6q_config
+ make
+}
+
+package() {
+ cd u-boot-imx6-${_commit}
+
+ mkdir -p "${pkgdir}"/boot/extlinux
+ cp u-boot.imx "${pkgdir}"/boot
+ cp "${srcdir}"/extlinux.conf "${pkgdir}"/boot/extlinux
+}