summaryrefslogtreecommitdiff
path: root/libre-testing/uboot-am335x_green/PKGBUILD
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>2021-12-12 22:45:00 +0100
committerDenis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>2021-12-12 22:45:32 +0100
commit49fef4a963e1b2163a000a6b65e2f4d61bd171ae (patch)
tree89dcc01ec578373123b9ab188e9a3342df2a0772 /libre-testing/uboot-am335x_green/PKGBUILD
parenta95b393e7d22b42eb2d82b550f9995975ab33299 (diff)
downloadabslibre-49fef4a963e1b2163a000a6b65e2f4d61bd171ae.tar.gz
abslibre-49fef4a963e1b2163a000a6b65e2f4d61bd171ae.tar.bz2
abslibre-49fef4a963e1b2163a000a6b65e2f4d61bd171ae.zip
libre-testing: remove outdated u-boot packages
All these u-boot pakcages were consolidated in SOC specific packages instead of board specific pakcages in libre. In addition the libre packages are more recent and in sync with the Parabola armv7h installation manual. Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
Diffstat (limited to 'libre-testing/uboot-am335x_green/PKGBUILD')
-rw-r--r--libre-testing/uboot-am335x_green/PKGBUILD54
1 files changed, 0 insertions, 54 deletions
diff --git a/libre-testing/uboot-am335x_green/PKGBUILD b/libre-testing/uboot-am335x_green/PKGBUILD
deleted file mode 100644
index d6cf7003f..000000000
--- a/libre-testing/uboot-am335x_green/PKGBUILD
+++ /dev/null
@@ -1,54 +0,0 @@
-# U-Boot: BeagleBone Green
-# Maintainer: Isaac David <isacdaavid@at@isacdaavid@dot@info>
-
-pkgname=uboot-am335x_green
-_gitver='d5abcf94c7123167725fc22ace342f0d455093c1'
-pkgver=20170328.g${_gitver:0:10}
-pkgrel=1
-pkgdesc="U-Boot for BeagleBone Green (git version)"
-arch=('armv7h')
-url="http://git.denx.de/u-boot.git/"
-makedepends=('git' 'bc' 'uboot-tools')
-depends=('linux-libre')
-replaces=('uboot-beaglebone')
-conflicts=('uboot4extlinux-am335x_bone' 'uboot4grub-am335x_bone'
- 'grub-am335x_bone' 'uboot-am335x_bone')
-license=('GPL')
-install=${pkgname}.install
-source=("u-boot-${_gitver:0:10}::git+http://git.denx.de/u-boot.git"
- '0001-am335x_evm-uEnv.txt-bootz-n-fixes.patch'
- '0002-Forward-port-parabola-patch.patch'
- '0003-Beaglebone-green.patch'
- 'uEnv.txt'
- 'boot.cmd')
-sha256sums=('SKIP'
- 'c02bdad650f62e5fc465a2113f9b8c19f55833afc99d14230952cce712496502'
- 'ca21d84c57f31878ee3288f52450dc09d5dc9de807de77d5bdf7d9b88d8dba59'
- '7a659bf26d6c126da41723b6005d95fe0bb1e989ee42134104fbb757bb108c90'
- '4ef3c3177e4476cdb1790dd021d2383ef9913c029d005ffbeb61b958e753672e'
- '34e920015ba60acebd443b5d4d9b060cc9ae8aa6ed5f405f86645b6cdec0dbc1')
-
-prepare() {
- cd u-boot-${_gitver:0:10}
- git reset --hard ${_gitver}
- patch -Np1 -i ../0001-am335x_evm-uEnv.txt-bootz-n-fixes.patch
- patch -Np1 -i ../0002-Forward-port-parabola-patch.patch
- patch -Np1 -i ../0003-Beaglebone-green.patch
-}
-
-build() {
- cd u-boot-${_gitver:0:10}
-
- unset CFLAGS CXXFLAGS LDFLAGS
-
- make distclean
- make am335x_evm_config
- make
- mkimage -A arm -O linux -T script -C none -d "${srcdir}"/boot.cmd boot.scr
-}
-
-package() {
- cd u-boot-${_gitver:0:10}
- mkdir -p "${pkgdir}"/boot
- cp MLO u-boot.img boot.scr "${srcdir}"/uEnv.txt "${pkgdir}"/boot
-}