summaryrefslogtreecommitdiff
path: root/libre-testing/uboot-am335x_bone/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2016-02-21 22:55:31 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2016-02-21 22:56:14 -0300
commit5927566d0d040a34912b975668ce1ce16ee25d6d (patch)
treee696a600c70aaf3a194f2a900a199f9b15ffcf56 /libre-testing/uboot-am335x_bone/PKGBUILD
parent92fd05db36899a777ccfe4fb0f625730e3c769fc (diff)
downloadabslibre-5927566d0d040a34912b975668ce1ce16ee25d6d.tar.gz
abslibre-5927566d0d040a34912b975668ce1ce16ee25d6d.tar.bz2
abslibre-5927566d0d040a34912b975668ce1ce16ee25d6d.zip
uboot-am335x_bone: add new package to [libre-testing]
Diffstat (limited to 'libre-testing/uboot-am335x_bone/PKGBUILD')
-rw-r--r--libre-testing/uboot-am335x_bone/PKGBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/libre-testing/uboot-am335x_bone/PKGBUILD b/libre-testing/uboot-am335x_bone/PKGBUILD
new file mode 100644
index 000000000..bfce9b132
--- /dev/null
+++ b/libre-testing/uboot-am335x_bone/PKGBUILD
@@ -0,0 +1,47 @@
+# U-Boot: BeagleBone and BeagleBone Black
+# Maintainer: André Silva <emulatorman@parabola.nu>
+
+buildarch=4
+
+pkgname=uboot-am335x_bone
+pkgver=2015.04
+pkgrel=1
+pkgdesc="U-Boot for Beaglebone and Beaglebone Black"
+arch=('armv7h')
+url="http://git.denx.de/u-boot.git/"
+replaces=('uboot-beaglebone')
+conflicts=('uboot-beaglebone')
+provides=('uboot-beaglebone')
+makedepends=('bc')
+license=('GPL')
+install=${pkgname}.install
+source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver}.tar.bz2"
+ '0001-parabola-arm-modifications.patch'
+ 'extlinux.conf'
+ 'uEnv.txt')
+md5sums=('570bdc2c47270c2a98ca60ff6c5c74cd'
+ '4f4078a4d5558a56a9144b7e8ed94fb5'
+ '9bf446920d4344d17eb0673b7a49701a'
+ 'ccb79775b81654e16fca18825c7f2506')
+
+prepare() {
+ cd u-boot-${pkgver}
+ patch -Np1 -i ../0001-parabola-arm-modifications.patch
+}
+
+build() {
+ cd u-boot-${pkgver}
+
+ unset CFLAGS CXXFLAGS LDFLAGS
+
+ make distclean
+ make am335x_evm_config
+ make
+}
+
+package() {
+ cd u-boot-${pkgver}
+ mkdir -p "${pkgdir}"/boot/extlinux
+ cp MLO u-boot.img "${srcdir}"/uEnv.txt "${pkgdir}"/boot
+ cp "${srcdir}"/extlinux.conf "${pkgdir}"/boot/extlinux
+}