summaryrefslogtreecommitdiff
path: root/libre-testing/linux-libre/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-02-01 05:31:18 -0200
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-02-01 05:31:18 -0200
commit05535758531123dd901f5e138ab0ced86f975bd9 (patch)
tree6d7c4ae64d00f22b73af6dfa23884d82ee960b12 /libre-testing/linux-libre/PKGBUILD
parentbdff7426b28ccae584227d40b11959ec44a00542 (diff)
downloadabslibre-05535758531123dd901f5e138ab0ced86f975bd9.tar.gz
abslibre-05535758531123dd901f5e138ab0ced86f975bd9.tar.bz2
abslibre-05535758531123dd901f5e138ab0ced86f975bd9.zip
linux-libre-3.13.1-2: fix CVE-2014-0038
Diffstat (limited to 'libre-testing/linux-libre/PKGBUILD')
-rw-r--r--libre-testing/linux-libre/PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/libre-testing/linux-libre/PKGBUILD b/libre-testing/linux-libre/PKGBUILD
index e295e81ad..c9368029f 100644
--- a/libre-testing/linux-libre/PKGBUILD
+++ b/libre-testing/linux-libre/PKGBUILD
@@ -12,8 +12,8 @@ pkgbase=linux-libre # Build stock -LIBRE kernel
_basekernel=3.13
_sublevel=1
pkgver=${_basekernel}.${_sublevel}
-pkgrel=1
-_lxopkgver=${_basekernel}.0 # nearly always the same as pkgver
+pkgrel=2
+_lxopkgver=${_basekernel}.1 # nearly always the same as pkgver
arch=('i686' 'x86_64' 'mips64el')
url="http://linux-libre.fsfla.org/"
license=('GPL2')
@@ -38,7 +38,8 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gn
'0006-rpc_pipe-fix-cleanup-of-dummy-gssd-directory-when-no.patch'
'0001-syscalls.h-use-gcc-alias-instead-of-assembler-aliase.patch'
'i8042-fix-aliases.patch'
- "http://www.linux-libre.fsfla.org/pub/linux-libre/lemote/gnewsense/pool/debuginfo/linux-patches-${_lxopkgver}-gnu_0loongsonlibre_mipsel.tar.bz2")
+ '0001-x86-x32-Correct-invalid-use-of-user-timespec-in-the-.patch'
+ "http://www.linux-libre.fsfla.org/pub/linux-libre/lemote/gnewsense/pool/debuginfo/linux-patches-${_lxopkgver}-gnu_0loongsonlibre_mipsel.tar.xz")
md5sums=('98a8e803e0ed08557f3cdd4d56b0ddc1'
'312e6bf90c4de3f455669f8cccf4eddd'
'b6a3a3f9cac1be38384241ad58d45d46'
@@ -56,8 +57,9 @@ md5sums=('98a8e803e0ed08557f3cdd4d56b0ddc1'
'd5907a721b97299f0685c583499f7820'
'a724515b350b29c53f20e631c6cf9a14'
'e6fa278c092ad83780e2dd0568e24ca6'
- '47fc9cc705752f1f16db23383504e194'
- '7e16faa84d4cd04e43bca12bdf9d9e4b')
+ '93dbf73af819b77f03453a9c6de2bb47'
+ '336d2c4afd7ee5f2bdf0dcb1a54df4b2'
+ '7710668dfdd138f3ad0b93c50455455e')
if [ "$CARCH" != "mips64el" ]; then
# don't use the Loongson-specific patches on non-mips64el arches.
unset source[${#source[@]}-1]
@@ -110,6 +112,9 @@ prepare() {
# Fix i8042 aliases
patch -p1 -i "${srcdir}/i8042-fix-aliases.patch"
+ # Fix CVE-2014-0038
+ patch -p1 -i "${srcdir}/0001-x86-x32-Correct-invalid-use-of-user-timespec-in-the-.patch"
+
if [ "$CARCH" == "mips64el" ]; then
sed -i "s|^EXTRAVERSION.*|EXTRAVERSION =-libre|" Makefile
sed -r "s|^( SUBLEVEL = ).*|\1$_sublevel|" \