summaryrefslogtreecommitdiff
path: root/kernels/linux-libre-xen/PKGBUILD
diff options
context:
space:
mode:
authorNicolás Reynolds <fauno@endefensadelsl.org>2014-02-03 14:09:45 -0300
committerNicolás Reynolds <fauno@endefensadelsl.org>2014-02-03 14:09:45 -0300
commit308f6ff034c928c0c4fc2ce168df7192ca2b1209 (patch)
tree49603bf604b0d3b3e4e0f1d71d0a52380933aa36 /kernels/linux-libre-xen/PKGBUILD
parent99d72f453ab00a43e11f6903bf34d6cd27962a4f (diff)
parent964755f48fefde84fce71781d0744e2158f60814 (diff)
downloadabslibre-308f6ff034c928c0c4fc2ce168df7192ca2b1209.tar.gz
abslibre-308f6ff034c928c0c4fc2ce168df7192ca2b1209.tar.bz2
abslibre-308f6ff034c928c0c4fc2ce168df7192ca2b1209.zip
Merge branch 'master' of vparabola:abslibre
Conflicts: pcr/pandoc/PKGBUILD
Diffstat (limited to 'kernels/linux-libre-xen/PKGBUILD')
-rw-r--r--kernels/linux-libre-xen/PKGBUILD20
1 files changed, 14 insertions, 6 deletions
diff --git a/kernels/linux-libre-xen/PKGBUILD b/kernels/linux-libre-xen/PKGBUILD
index 4a3460e36..0422e563d 100644
--- a/kernels/linux-libre-xen/PKGBUILD
+++ b/kernels/linux-libre-xen/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 203524 2014-01-12 13:05:55Z tpowa $
+# $Id: PKGBUILD 204911 2014-01-31 09:59:51Z bluewind $
# Contributor: Tobias Powalowski <tpowa@archlinux.org>
# Contributor: Thomas Baechler <thomas@archlinux.org>
# Maintainer (Parabola): André Silva <emulatorman@parabola.nu>
@@ -6,7 +6,7 @@
pkgbase=linux-libre-xen # Build stock -LIBRE-XEN kernel
#pkgbase=linux-libre-custom # Build kernel with a different name
_basekernel=3.12
-pkgver=${_basekernel}.7
+pkgver=${_basekernel}.9
pkgrel=2
arch=('i686')
url="http://linux-libre.fsfla.org/"
@@ -27,9 +27,10 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gn
'nfs-check-gssd-running-before-krb5i-auth.patch'
'rpc_pipe-remove-the-clntXX-dir-if-creating-the-pipe-fails.patch'
'sunrpc-add-an-info-file-for-the-dummy-gssd-pipe.patch'
- 'rpc_pipe-fix-cleanup-of-dummy-gssd-directory-when-notification-fails.patch')
+ 'rpc_pipe-fix-cleanup-of-dummy-gssd-directory-when-notification-fails.patch'
+ '0001-x86-x32-Correct-invalid-use-of-user-timespec-in-the-.patch')
md5sums=('254f59707b6676b59ce5ca5c3c698319'
- 'c42ff446236915fe1a6e2b6f9724d267'
+ '348975e36e4dd27f5d8fc50e92de8922'
'670682e633d1b785c73581307da7eb9c'
'b7c2805bb287a644c0a303bf7721e534'
'44260d2cb1a8b51c119d2ce1f83e457a'
@@ -40,7 +41,8 @@ md5sums=('254f59707b6676b59ce5ca5c3c698319'
'88eef9d3b5012ef7e82af1af8cc4e517'
'cec0bb8981936eab2943b2009b7a6fff'
'88d9cddf9e0050a76ec4674f264fb2a1'
- 'cb9016630212ef07b168892fbcfd4e5d')
+ 'cb9016630212ef07b168892fbcfd4e5d'
+ '336d2c4afd7ee5f2bdf0dcb1a54df4b2')
_kernelname=${pkgbase#linux-libre}
_localversionname=-LIBRE-XEN
@@ -58,6 +60,9 @@ prepare() {
# fix issue on Hal8188EFWImg_CE.c deblobbed file
sed -i "\|DEBLOBBED| s|,||" drivers/staging/rtl8188eu/hal/Hal8188EFWImg_CE.c
+ # add latest fixes from stable queue, if needed
+ # http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git
+
# set DEFAULT_CONSOLE_LOGLEVEL to 4 (same value as the 'quiet' kernel param)
# remove this when a Kconfig knob is made available by upstream
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
@@ -67,7 +72,7 @@ prepare() {
# patch from fedora
patch -Np1 -i "${srcdir}/criu-no-expert.patch"
- # fix 15 seocnds nfs delay
+ # fix 15 seconds nfs delay
patch -Np1 -i "${srcdir}/sunrpc-create-a-new-dummy-pipe-for-gssd-to-hold-open.patch"
patch -Np1 -i "${srcdir}/sunrpc-replace-gssd_running-with-more-reliable-check.patch"
patch -Np1 -i "${srcdir}/nfs-check-gssd-running-before-krb5i-auth.patch"
@@ -78,6 +83,9 @@ prepare() {
patch -Np1 -i "${srcdir}/rpc_pipe-fix-cleanup-of-dummy-gssd-directory-when-notification-fails.patch"
+ # Fix CVE-2014-0038
+ patch -p1 -i "${srcdir}/0001-x86-x32-Correct-invalid-use-of-user-timespec-in-the-.patch"
+
cat "${srcdir}/config" > ./.config # simpler
if [ "${_kernelname}" != "" ]; then