summaryrefslogtreecommitdiff
path: root/cross/mips64el-unknown-linux-gnu-binutils/PKGBUILD
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2012-02-26 21:53:52 -0500
committerLuke Shumaker <LukeShu@sbcglobal.net>2012-02-26 21:53:52 -0500
commit7275399e96c64abc852c3746aa58d10bee8a5a44 (patch)
treea798ae34656585ec83f390dac95382ccc303919c /cross/mips64el-unknown-linux-gnu-binutils/PKGBUILD
parent4bfc44a83c098d0f6d731b855541140fac36b8aa (diff)
parent31763e92611731c859ccbe4e97019afabb5ef91e (diff)
downloadabslibre-7275399e96c64abc852c3746aa58d10bee8a5a44.tar.gz
abslibre-7275399e96c64abc852c3746aa58d10bee8a5a44.tar.bz2
abslibre-7275399e96c64abc852c3746aa58d10bee8a5a44.zip
Merge branch 'master' of ssh://parabolagnulinux.org:1863/abslibre
Diffstat (limited to 'cross/mips64el-unknown-linux-gnu-binutils/PKGBUILD')
-rw-r--r--cross/mips64el-unknown-linux-gnu-binutils/PKGBUILD53
1 files changed, 53 insertions, 0 deletions
diff --git a/cross/mips64el-unknown-linux-gnu-binutils/PKGBUILD b/cross/mips64el-unknown-linux-gnu-binutils/PKGBUILD
new file mode 100644
index 000000000..0349036ec
--- /dev/null
+++ b/cross/mips64el-unknown-linux-gnu-binutils/PKGBUILD
@@ -0,0 +1,53 @@
+# Contributor: Vojtech Horky <vojta . horky at-symbol seznam . cz>
+
+_pkgname=binutils
+_target="mips64el-unknown-linux-gnu"
+_sysroot="/usr/${_target}"
+
+unset CFLAGS CXXFLAGS LDFLAGS
+
+pkgname=${_target}-binutils
+pkgver=2.22
+pkgrel=1
+pkgdesc="A set of programs to assemble and manipulate binary and object files for the MIPS architecture"
+url="http://www.gnu.org/software/binutils/"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('zlib')
+provices=("cross-${pkgname}")
+source=("ftp://ftp.gnu.org/gnu/binutils/${_pkgname}-${pkgver}.tar.bz2")
+md5sums=('ee0f10756c84979622b992a4a61ea3f5')
+
+build() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+
+ CFLAGS=" -pipe "\
+ CXXFLAGS=" -pipe "\
+ ./configure --build=${CHOST} \
+ --host=${CHOST} \
+ --target=${_target} \
+ --prefix=/usr \
+ --disable-nls \
+ --disable-multilib \
+ --disable-werror \
+ --enable-ld=yes \
+ --enable-gold=no \
+ --with-sysroot=${_sysroot}
+
+ make
+}
+
+package() {
+
+ cd ${srcdir}/${_pkgname}-${pkgver}
+# Compat symlinks
+ ln -s ${_sysroot}/usr/lib ${pkgdir}${_sysroot}/lib
+ ln -s ${_sysroot}/lib ${pkgdir}${_sysroot}/lib32
+
+ make DESTDIR=${pkgdir} install
+
+ rm -r ${pkgdir}/usr/{lib,share}
+
+# Create include dir so gcc-core doesn't complain
+ mkdir -p ${pkgdir}${_sysroot}/usr/include
+}