summaryrefslogtreecommitdiff
path: root/artistic/spacenavd/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@lavabit.com>2012-07-12 22:43:28 -0300
committerAndré Fabian Silva Delgado <emulatorman@lavabit.com>2012-07-12 22:43:28 -0300
commiteb9a9b697eb07e5b7afa4349c5055113823eb439 (patch)
tree5c215925a9c420409c71238a98b8ba11c373fca5 /artistic/spacenavd/PKGBUILD
parent9c2b79f31e212ff4c4a7f3b58673168288562835 (diff)
parentf944490c481c2665eb788d6b985bf5046407b870 (diff)
downloadabslibre-eb9a9b697eb07e5b7afa4349c5055113823eb439.tar.gz
abslibre-eb9a9b697eb07e5b7afa4349c5055113823eb439.tar.bz2
abslibre-eb9a9b697eb07e5b7afa4349c5055113823eb439.zip
Merge branch 'master' of ssh://parabolagnulinux.org:1863/srv/git/abslibre
Diffstat (limited to 'artistic/spacenavd/PKGBUILD')
-rw-r--r--artistic/spacenavd/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/artistic/spacenavd/PKGBUILD b/artistic/spacenavd/PKGBUILD
new file mode 100644
index 000000000..1c117b804
--- /dev/null
+++ b/artistic/spacenavd/PKGBUILD
@@ -0,0 +1,23 @@
+# Contributor: Jan Hambrecht <jaham at gmx dot net>
+# Maintainer (Parabola): Márcio Silva <coadde@lavabit.com>
+
+pkgname=spacenavd
+pkgver=0.5
+pkgrel=1
+pkgdesc="The spacenav project provides a free, compatible alternative, to the proprietary 3Dconnexion device driver and SDK, for their 3D input devices (called 'space navigator', 'space pilot', 'space traveller', etc)."
+arch=('i686' 'x86_64' 'mips64el')
+url="http://spacenav.sourceforge.net/"
+license=('GPL')
+depends=('libx11')
+backup=('etc/spnavrc')
+source=(http://downloads.sourceforge.net/spacenav/$pkgname-$pkgver.tar.gz spacenavd )
+
+md5sums=('0bb21da5315bd376aa508157a9455aaa'
+ '27a739300d4de07920879af2d2bdd47f')
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ ./configure --prefix=$pkgdir/usr
+ make || return 1
+ make DESTDIR=$pkgdir install || return 1
+ install -D -m755 $srcdir/spacenavd $pkgdir/etc/rc.d/spacenavd || return 1
+}